Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I attempt to install aircrack-ng in terminal I get the following error:

Package aircrack-ng is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  iw

E: Package 'aircrack-ng' has no installation candidate"

I'm new to buntu and so have no idea whUat to do. :P
Any suggestions?
And if so try your best to do it in english terms. :)

share|improve this question
    
i downloaded the tar ball and compiled it... –  Nirmik May 25 '12 at 9:28
    
Has any of the offered answers helped? Please click the checkmark if any of them has. –  Exeleration-G May 29 '12 at 21:30

4 Answers 4

It has been removed from ubuntu repositories as message says. you can install it by doing following procedure

1) sudo apt-get install build-essential

2) sudo apt-get install libssl-dev

3) wget http://download.aircrack-ng.org/aircrack-ng-1.1.tar.gz

4) tar -zxvf aircrack-ng-1.1.tar.gz

5) cd aircrack-ng-1.1

5) In the aircrack-ng-1.1 directory there is a file called common.mak, use your favorite editor to open the file and scroll down till you see the following line:

CFLAGS ?= -g -W -Wall -Werror -O3

Delete the -Werror variable, so that the line now looks like the following. Save and exit.

CFLAGS ?= -g -W -Wall -O3

6) Run make and sudo make install in terminal to get aircrack-ng up and running."

for build-essential go to update manager > settings > ubuntu softwares and see if top main is checked.

enter image description here

share|improve this answer
    
when i do the first instruction : 'sudo apt-get install build-essential' i get the response ( Package build-essential is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'build-essential' has no installation candidate ) –  Chris May 25 '12 at 9:45
    
That is an essential part of ubuntu, it should work. please check you typed it correctly. and also you mentioned in comments about libc6. whenever some application tries to give you this kind of message, copy that (e.g libc6) and paste it in synpatic package manager, then install it. –  wedu May 25 '12 at 10:35
    
or for libc6 enter in terminal sudo apt-get install libc6 –  wedu May 25 '12 at 10:48
    
It works for me on Ubuntu 12.04 –  SuB Oct 10 '13 at 7:41

I have it in a PPA for precise. I did it for another question. If you need directions for adding a PPA they're here.

share|improve this answer
    
Lol was going to mention this here. That I knew that the user aking has a PPA with it. Already installed aircrack from there. Thanks buddy. –  Luis Alvarado May 27 '12 at 3:36

Looks like it's not in the repositories anymore. I know that aircrack-ng was in the Ubuntu 10.10 repositories, so you might want to try using Ubuntu 10.10 instead of the current version (12.04). But you can also install it in 12.04, using another way. You'll then install aircrack-ng using a .deb file. You just double-click on this file, and it will be opened in the Ubuntu Software Center. To get the .deb file for a 32-bit Ubuntu install (i386), click here. If you're using a 64-bit Ubuntu install (amd64), click here.

share|improve this answer
    
i see, ok well is there another type of thing that is the same as aircrack-ng for the new version (12.04) ? –  Chris May 25 '12 at 9:42
    
Yes, the files I'm referring to are installable on Ubuntu 12.04. –  Exeleration-G May 25 '12 at 9:46
    
And those files are the 'real' aircrack-ng, what you're talking about. –  Exeleration-G May 25 '12 at 9:48
    
i clicked there and it went to software centre and i could see the aircrack-ng and the page is greyed out and i cant press anything also there is a message saying ' dependancy is not satisfiable: libc6 (>=2.7) –  Chris May 25 '12 at 9:51
    
That's strange. On my install, it went just fine. Your best option then would be to follow @aking1012 's solution, because that's relatively easy as well. –  Exeleration-G May 25 '12 at 9:58

Debian packages are available here : http://ubuntu2.cica.es/ubuntu/ubuntu/pool/universe/a/aircrack-ng/

You need to download the respective package architecture

wget http://ubuntu2.cica.es/ubuntu/ubuntu/pool/universe/a/aircrack-ng/aircrack-ng_1.1-6_amd64.deb

dpkg -i aircrack-ng_1.1-6_amd64.deb

Here is the help command

root@chillax:/usr/local/src# aircrack-ng --help

Aircrack-ng 1.1 - (C) 2006, 2007, 2008, 2009 Thomas d'Otreppe
Original work: Christophe Devine http://www.aircrack-ng.org

usage: aircrack-ng [options] <.cap / .ivs file(s)>

Common options:

  -a <amode> : force attack mode (1/WEP, 2/WPA-PSK)
  -e <essid> : target selection: network identifier
  -b <bssid> : target selection: access point's MAC
  -p <nbcpu> : # of CPU to use  (default: all CPUs)
  -q         : enable quiet mode (no status output)
  -C <macs>  : merge the given APs to a virtual one
  -l <file>  : write key to file

Static WEP cracking options:

  -c         : search alpha-numeric characters only
  -t         : search binary coded decimal chr only
  -h         : search the numeric key for Fritz!BOX
  -d <mask>  : use masking of the key (A1:XX:CF:YY)
  -m <maddr> : MAC address to filter usable packets
  -n <nbits> : WEP key length :  64/128/152/256/512
  -i <index> : WEP key index (1 to 4), default: any
  -f <fudge> : bruteforce fudge factor,  default: 2
  -k <korek> : disable one attack method  (1 to 17)
  -x or -x0  : disable bruteforce for last keybytes
  -x1        : last keybyte bruteforcing  (default)
  -x2        : enable last  2 keybytes bruteforcing
  -X         : disable  bruteforce   multithreading
  -y         : experimental  single bruteforce mode
  -K         : use only old KoreK attacks (pre-PTW)
  -s         : show the key in ASCII while cracking
  -M <num>   : specify maximum number of IVs to use
  -D         : WEP decloak, skips broken keystreams
  -P <num>   : PTW debug:  1: disable Klein, 2: PTW
  -1         : run only 1 try to crack key with PTW

WEP and WPA-PSK cracking options:

  -w <words> : path to wordlist(s) filename(s)
  -r <DB>    : path to airolib-ng database
               (Cannot be used with -w)

  --help     : Displays this usage screen

See here for more : http://www.aircrack-ng.org/doku.php?id=downloads

share|improve this answer

protected by Community Aug 8 '12 at 12:09

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.