Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Before upgrading to 12.04, the language indicator used to change every time I was sending LibreOffice to the background and making Firefox the active application/window.

This was convenient enough as I didn't have to manually change the input language each time I needed to search for a term in English in the web or in a dictionary, and then change it again to Greek in order to continue typing.

Now, this is exactly what's happening after upgrading to 12.04.

How can I manage to make the language flag change every time I switch between applications?

share|improve this question

1 Answer 1

Try looking in the Advanced tab of the Ibus settings gui (type ibus into the dash or hit Alt+F2 and run ibus-setup to find this gui) and unchecking Share the same input method among all applications if it is checked (see below).

ibus settings

I cannot reproduce your problem using Libreoffice, Firefox and a Chinese input method, but I noticed this box is not checked for me. Maybe the upgrade process somehow enabled this setting for you (although its weird that it didn't do the same for me....).

Good luck!

share|improve this answer
    
I checked ibus and deselected "Share the same input method among all applications" option, but it didn't work even after login out and back in from the user's account...! Shouldn't this be an issue of gconf...? –  anvo May 25 '12 at 10:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.