Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am new to Ubuntu/Linux and am stuck already! Any help much appreciated.

I have managed to install Ubuntu Maverick 10.10 (from a USB flash drive) on my NC10 which also has Windows 7 on the partitioned drive.

But the wireless internet is not working. I have identified the hardware as a Broadcom BCM4313. I have also managed to find that the correct driver is installed (Modaliases for Broadcom 802.11 Linux STA driver).

I have followed advice from elsewhere and there does not seem to be any competition from other drivers.

I am now stuck and do not have any other internet access on this netbook.

Any ideas?

share|improve this question

closed as too localized by Marco Ceppi Jan 24 '12 at 15:56

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

By "wireless not working", do you mean you are unable to see wireless networks, or that your system does not detect the card, or that you cannot connect to any networks, but you can see them? – Thomas Ward Apr 12 '11 at 18:32
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) – James Jan 24 '12 at 14:04

Ok for starters :)

Go to synaptic package manager which is in system > administration.

Then in that long list see if bcmwl-kernel-source is installed. Its just a check anyway. Otherwise if it is not, install that. Next thing, under system > administration go to hardware drivers. you should see Broadcom STA driver or similar. See if it is activated (it should have a green circle on its left) if its not, do activate it and let us know how it goes. The modaliases entry that you saw just allows the system to figure out what broadcom card it is and what to do about it maybe.

share|improve this answer

I would support that but I would also take the precaution of removing any older packages first (give you system a little spring clean). I regularly have to reinstall my broadcom wireless drivers and this can be a bit of a pain so:

In a terminal (ctrl -alt - t) type the following

sudo apt-get purge bcmwl-kernel-source*

this cleans out any installed correctly or incorrectly packages then

sudo apt-get install bcmwl-kernel-source

This should then reinstall it correctly and you should see it install then recognise your wireless card and install a application called wl.ko in the terminal.

I would then reboot your netbook and you should then find it reboots with a message that says something like wireless networks on the icon on the top and select your network.

Let us know how you get on

share|improve this answer

For my Natty laptop it worked by blacklisting the acer_wmi module, don't know if it works with Maverick.



and add the following line at the end

blacklist acer_wmi

please tell us what method worked out for you.

share|improve this answer