Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used to be able to use my Arctic P311 bluetooth headset for both, input and output, but now I can't. Well, it works fine as an output device but when I try to set it as a default input device in Sound Settings, settings windows breaks and goes down. At first it showed popups to report the problem but now it doesn't. It just dies now. I don't even know what is the problem.

How do I launch that application from terminal to see what it outputs? And/or maybe someone knows a potential problem?

P.S. Ubuntu 12.04 x64

EDIT

Thanks to the reply, I can now change input source but I now can't change output source. But it's because sound settings application crashes instantly as it shows up.

share|improve this question
    
If you are suing pulseaudo, you can configure the default input device by pavucontrol. –  Xiè Jìléi May 25 '12 at 6:19
    
See edit below on how to change the output. –  Takkat May 25 '12 at 19:36
add comment

1 Answer 1

up vote 4 down vote accepted

Changing input source from command line

To see if an input source is defined, and to manually set a source as default for pulseaudio we may issue the following commands from a terminal:

pacmd list-sources # gives a list of all available sources
pacmd set-default-source <index or name> # changes the input default source

The index or name of the source is given in the first command. For a Bluetooth device connected through Bluez the source name will be:

bluez_source.xx_xx_xx_xx_xx_xx

Where xx_xx_xx_xx_xx_xx is the MAC of your headset (replace : by _).

Changing output sink from command line

Changing the output sink from command line can be done likewise by using the follwing commands

pacmd list-sinks #shows all sinks available
pacmd set-default-sink <index or name> # sets the output default sink

Autoconnect Bluetooth headset with pulseaudio

By editing /etc/pulse/default.pa (as root) we can load the module-switch-on-connect that enables the sound server to automatically switch to the headset when it becomes available. After making a backup (to be able to revert changes in case something breaks) insert the following line to your default.pa

load-module module-switch-on-connect

To take effect we need to restart the pulseaudio server (run pulseaudio -k).

share|improve this answer
    
That worked but now Sound Settings can't open (crashes while loading) to change output source. It seems like current Sound Settings application has problems with bluetooth. –  Pius May 25 '12 at 15:31
    
Yeah there are many issues/crashes reported with bluetooth and gnome-control-center. Hard to tell, which one applies to your issue. –  Takkat May 25 '12 at 17:25
    
For me, this temporarily broke Gnome-Shell, disabling my keyboard and ability to switch windows, but after a hard reboot my headset was properly auto-connected and selected as the output device. –  Cerin Sep 4 '12 at 20:35
    
Yeah, switch-on-connect worked for me in 12.03. Thanks! –  dabisu Sep 16 '13 at 1:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.