Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to remote desktop from one Ubuntu machine to another. I can ssh from client to server successfully. On the server machine I set up everything that is mentioned in the guides (Remote Desktop Preferences), but every time I am trying to remote desktop to server from client I get error "Unable to connect". Do I need to set anything up on the server besides what I already did? Can I see somewhere why I couldn't connect?

share|improve this question
Did you install SSH 'server' on the target machine? The 'OpenSSH client' is installed by default on Ubuntu (desktop or server), which allows you to connect to a machine that has SSH server. sudo apt-get install openssh-server – david6 May 25 '12 at 4:39
Yes, I have it installed. When I tried to connect yesterday and was not successful on the server machine I got message that reads something like "Following machine wants to remote desktop to your machine.", I chose 'Allow' but still couldn't connect. I should mention that machine I am trying to connect to is a work machine and I am connecting from home. I don't have problem ssh-ing into work machine, but not sure if this is a good indicator that connection can be established. – akravets May 25 '12 at 13:40
up vote 0 down vote accepted

In Dash, find or search for Desktop Sharing, configure that and you can then graphically control another machine. This sets up a VNC connection that you can use. If there is no one on the other end when connecting to a machine, make sure that you require a password and disable "You must confirm each access to this machine"

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.