Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had a separate partition made for Linux Mint which installed just fine and I had used for about a month (new linux user), while having Windows 7 dual-booted so I could play games on Steam. I decided to switch to Ubuntu, and I tried installing it the same way I installed Mint.

I put Ubuntu on a USB drive, booted with usb, installed from Ubuntu, clicked on Something Else (other then over windows), and picked the partition I made for Mint. I formatted it and used the ext4 filesystem and no swap space, the installation went just fine. At the end it told me to restart and when I did, not only did my Ubuntu Partition go missing, so did my D:\ Drive which had all of my steam games, some school files, and my System Image folder (unfortunately). This is my partitions viewed from Windows 7

What are my options

edit: Im willing to reset my laptop to factory if I have to, to fix it

edit2: I have an Asus K53-SV Laptop

edit3: I can see my drives again in gparted but how can I fix grub so I can run ubuntu

edit4: Grub doesn't seem to be installed when I look for it in the ubuntu software centre (keep in mind im a brand new linux user)

share|improve this question
    
It's difficult to know for sure what happened. On the screenshot of your partitions, was the greyed partition your D: drive? You have four primary partitions: the second is Windows, so which was which of the others? –  Kelley May 25 '12 at 3:08
    
It was greyed just because I clicked it, but it was my D drive, the 4th was my Partition I made for Linux, and the first I actually have no Idea. –  fatboy100 May 25 '12 at 3:10

1 Answer 1

up vote 1 down vote accepted

Wait! Don't reformat yet...

What probably happened is that Windows cannot see the ext4 partitions. Boot with your Ubuntu live cd and use Gparted. It should see the partitions. Use it to fix the Grub.

Let me know if it works. I'm writing like a bat-out-of-hell to keep you from formatting!

share|improve this answer
    
lol thank you! I'll try it –  fatboy100 May 25 '12 at 3:14
    
Sweet you were right about Windows not seeing the ext4 partitions. I'm just not really sure what to do from here to fix my problem. It doesn't give me the option to boot with ubuntu when I start my computer –  fatboy100 May 25 '12 at 3:29
    
Boot from live CD (much better if you prepare a live USB memory with some "persistence space"), download Boot Repair with Software Center (Dash > Software Center). Run it. Let it find the operating systems and partitions and have it install Grub on your MAIN drive (not partition), usually dev/sda. When you reboot it should take you to whatever OS you have chosen as default. You can change that later by means of Grub Customizer. –  Jorge M. Treviño May 25 '12 at 7:30
    
PS, GParted and the other two apps, which are essential IMHO, are not installed by default in the definite installation. Be sure to add them when you have everything running. –  Jorge M. Treviño May 25 '12 at 7:37
    
Thank you for your help. My D: drive still isn't viewable on windows even though the filesystem can be read on windows. It's strange but I'm not so sure I care I think I might just dedicate that whole drive to ubuntu. Edit - I just found out that when I installed ubuntu it automatically used my D: drive for swap space. I guess that also locks it from windows. –  fatboy100 May 26 '12 at 18:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.