Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to disable the touchpad. I want to keep the trackstick. Is it possible?

The Alps touchpad is recognized by the kernel as a PS/2 Generic Mouse. Not all its features are supported by the kernel yet.

Only a single /dev/input/event12 device is provided for both the touchpad and the trackstick. Yet it seems that windows allows to disable the touchpad.

share|improve this question

20 Answers 20

up vote 14 down vote accepted
+100

The failure to recognise the touchpad and fallback to identifying it as a PS2 mouse is due to the hardware using a new protocol and the manufacturer not releasing the specs so that a free driver can be written.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/550625

The protocol has been mostly reverse engineered and there is now a fix involving a patched kernel module, but it isn't completely perfect (won't do multitouch) and hasn't yet found its way into the mainstream kernels. See the discussion for details. It also tells you how to do the patch if you feel brave enough to patch your kernel.

If all you want is to be able to quickly and easily disable the touchpad so you can type, then try setting up keyboard shortcuts as follows.

xinput --set-prop "PS/2 Generic Mouse" "Device Enabled" 0

will disable the touchpad while

xinput --set-prop "PS/2 Generic Mouse" "Device Enabled" 1

will enable it again. Being able to turn the touchpad on and off with a simple key combination makes the problem bearable while we wait for a better solution.

share|improve this answer
    
I had a similar problem with an HP trackpad. At least now it toggles on and off properly and the connection of a mouse doesn't cause it to go retarded unpredictably. I really think people have overly aggressive expectations of FREE stuff(if you are donating to ubuntu or debian I retract my previous remark). –  hbdgaf Nov 29 '10 at 21:09
    
Thanks for the tip, works perfectly on Dell Vostro 3550 –  silkAdmin Nov 4 '11 at 7:46
3  
Note that on recent kernels the touchpad correctly reports as "AlpsPS/2 ALPS DualPoint TouchPad" (Dell E6510). Get the names and ids of all input devices with xinput --list. –  kynan Aug 15 '12 at 6:07

I wrote a small touchpad toggle script that I have bound to the toggle touchpad function key on my e6520 (Fn+F5).

It uses the commands that Peter Torpman posted above.

#!/bin/bash                                                                                          
enabled=`xinput --list-props "ImPS/2 ALPS GlidePoint" | grep -e "Device Enabled\ (127):\s*1"`

if [ -n "$enabled" ]; then
    xinput --set-prop "ImPS/2 ALPS GlidePoint" "Device Enabled" 0
else
    xinput --set-prop "ImPS/2 ALPS GlidePoint" "Device Enabled" 1
fi
share|improve this answer
2  
Could please include information on how to bind the function to keys? –  N.N. Sep 28 '11 at 11:20
    
@N.N. on unity: System Settings -> Keyboard -> Shortcuts -> Custom Shortcuts. Add a shortcut with the name you saved the script as as the command (needs to be in your $PATH). –  kynan Aug 15 '12 at 6:05
    
FYI I'm using a slightly modified version on my E6510. –  kynan Aug 15 '12 at 6:44

I am restricted from downloading and installing drivers / software on a Dell Latitude laptop with the same worthless touchpad (the machine is owned and provided by my employer). My solution to disable the touchpad consists of a 5" x 2 3/4" piece of cardboard, approximately 1/8" thick, and a couple of pieces of tape. Works great! No more stray mouse pointer clobbering my work!

share|improve this answer
    
Using xinput as suggested by several other answers doesn't require any drivers/software, not even sudo! –  kynan Aug 15 '12 at 6:49

I simply unload the kernel module for the Touchpad on my Sony. Manual way:

To disable:

rmmod psmouse

To enable:

modprobe psmouse

Make it permanent in /etc/modprobe.d/blacklist.conf by adding:

blacklist psmouse

Hope this helps on your Dell....

share|improve this answer
1  
Thanks for a nice trick. Unfortunately, it disables also the trackstick. –  Ivo Danihelka Nov 22 '10 at 9:54

See if it helps you,edit the /etc/X11/xorg.conf file and add the Option SHMConfig on line to the section called “Input Device” for the Synaptic Touchpad input device.Then restart X (by using the ctrl+alt+backspace key combination).

Once I was logged in, I used syndaemon as syndaemon -t -d.The -t option specifies that only the tapping and scrolling actions are to be disabled,you can still move the cursor around while typing on the keyboard. The -d option asks syndaemon to run in the background as a daemon, so you don’t have to keep the terminal open after executing the command.

You can disable the touchpad entirely by not using the -t option.To make syndaemon start up by default each time you login, add it to the list of Startup Programs in System->Preferences->Sessions. I have the following command added there now: syndaemon -t -d.

share|improve this answer
1  
When I specify the synaptics driver for the device, it reports a failure: (--) PS/2 Generic Mouse: no supported touchpad found. And that disables both the touchpad and the trackstick. –  Ivo Danihelka Nov 20 '10 at 17:18

You may be interested in installing the gpointing-device-settings Install gpointing-device-settings, which will provide more configuration options for your touchpad. BTW, in Ubuntu 10.04LTS+ this replaces gsynaptics

Once installed you find it under System -> Preferences -> Pointing Devices.

share|improve this answer
1  
gpointing-device-settings sees the touchpad+trackstick only as PS/2 mouse. It is not possible to disable just the touchpad there. –  Ivo Danihelka Nov 24 '10 at 16:57

A possible alternative and something I use to extend the battery life of my old laptop is Jupiter. Jupiter is a power management app originally created for netbooks but it also works for real computers to. it gives you a couple of power modes and allows you to diable or enable wireless, bluetooth, external monitors plus and more importantly in your case the touchpad I'm not sure whether it will work but its worth a shot. It's not in the software centre but you can grab a deb from their sourceforge page here http://sourceforge.net/projects/jupiter/

Hope this helps

share|improve this answer

Seems like no other answer is currently able to solve your problem, so I'll offer what is probably a last resort! My brother's workplace used D series Dell Latitudes and he said he was able to physically disconnect the trackpad when it wasn't possible to disable it via software. I don't know how savvy you are hardware-wise, but here's a link to the service manual for an E5510, if you're feeling brave...

From the instructions for removing the palm rest, step 16 is Disconnect the touchpad data cable:

alt text

Don't know if this will disconnect the trackpad as well, but might be worth trying.

share|improve this answer
1  
I tried to disconnect exactly the same cable before. It disconnects also the trackstick and the keyboard :(. –  Ivo Danihelka Nov 29 '10 at 8:18
2  
I asked my brother about this the other day. What they did was find a pin-out and cut specific wires on the ribbon in order to disable one or the other. They had the luxury of having spare machines to test this on which, unfortunately, I imagine you don't! Sorry I couldn't be of more help. –  Roddie Dec 7 '10 at 20:46

I have a E6510 using Ubuntu 11.04 and I managed to turn the touchpad off using:

xinput --set-prop "ImPS/2 ALPS GlidePoint" "Device Enabled" 0

To turn it on, simply enter:

xinput --set-prop "ImPS/2 ALPS GlidePoint" "Device Enabled" 1

Cheers! / Peter

share|improve this answer
1  
I get unable to find device ImPS/2 ALPS GlidePoint :-( –  aioobe Sep 8 '11 at 19:36
1  
This does work for me under 11.04, but it disables the pointer stick as well. –  belacqua Sep 15 '11 at 17:13
    
I'm using a Touchpad toogle script on my E6510 on 11.10 –  kynan Aug 15 '12 at 6:46

Touchpad Indicator is a very simple indicator created by Lorenzo Carbonell (the Picapy developer), which as the name suggests, is designed to allow you to easily enable / disable your laptop or netbook touchpad.

To install Touchpad Indicator in Ubuntu (10.10 Maverick Meerkat only), you'll have to use the same PPA for Picapy: sudo add-apt-repository ppa:lorenzo-carbonell/atareao sudo apt-get update sudo apt-get install touchpad-indicator

Once installed, you'll find it under Applications > Accessories > Touchpad Indicator.

Source: http://www.webupd8.org/2010/11/touchpad-indicator-lets-you-quickly.html

share|improve this answer

I just got a Dell Latitude e6520 and the touchpad had no controls and could not be turned off. This is a problem since my thumb always hits it when I type and I prefer to hook up an external mouse. To solve, I simply went to the Dell Web Site "Drivers and Downloads" and went to "Mouse and Keyboards" and downloaded the touchpad driver. The driver installed itself and now I have touchpad controls. I can now disable my touchpad when I have an external mouse attached. I had to do the same thing with my wife's Dell laptop last year. I'm not sure why Dell doesn't provide this driver on a new laptop.

share|improve this answer

Disappointed with a) the inability to keep my thumbs off the touch pad while typing, b) the gross failure of Dell to include a simple software based control to enable/disable and adjust the sensitivity of the touch pad, c) the fact that three heavy stock business cards taped over the touch wasn't sufficient to insulate from my thumb, and d) the above software / hardware fixes were a little too technical for the average lap top user.... I think I found the best semi permanent solution to the problem.

Tape a small square of aluminum foil over the touch pad. Since the pad is a capacitor matrix that senses where your finger by capacitance measured to an array underneath, the foil has the effect of shorting all the capacitors together and blinding the pad the way business card stock could not. Works great, although it is not readily turned on and off the way some of the above solutions allow.

share|improve this answer

A driver is avaible on Dell's web site. http://www.dell.com/support/drivers/fr/fr/rc1077983/DriverDetails/DriverFileFormats?DriverId=C7P1W&FileId=2731098901

...and it works !

Suitable for 10 only. The above link is for french

share|improve this answer

Thanks for the disabling-script. Very useful. I am using Ubuntu 11.10 on an E5510 laptop and i had to make a little change. Device enabled return 126 not 127 so the modified-script is (line 2) :

#!/bin/bash                                                                                          
enabled=`xinput --list-props "ImPS/2 ALPS GlidePoint" | grep -e "Device Enabled\ (126):\s*1"`

if [ -n "$enabled" ]; then
    xinput --set-prop "ImPS/2 ALPS GlidePoint" "Device Enabled" 0
else
    xinput --set-prop "ImPS/2 ALPS GlidePoint" "Device Enabled" 1
fi

To find the code for your laptop, type "xinput --list-props "ImPS/2 ALPS GlidePoint" | grep -e "Device Enabled" into a terminal

share|improve this answer

My laptop is a Dell Latitude E6520. I use the Ubuntu 12.04 with a standard KDE 4.8 environment.

The touchpad is already recognized as "AlpsPS/2 ALPS DualPoint TouchPad". Firstly, create a shell script including the line synclient TouchpadOff=1. Then add this shell script to autostart items. Then restart KDE; the touchpad is disabled now.

share|improve this answer

On Latitude E6520, you can simply use Fn+F5 to disable/enable touchpad and touch stick.

This doesn't work on Ubuntu 11, although the laptop responds to the request, the touch pad still works.

share|improve this answer
    
OP wants to keep track/touch stick operational. –  belacqua Nov 2 '12 at 15:30

In Ubuntu 11, you can create custom shortcuts by typing shortcut or keyboard into the Dash Home or select Keyboard in Settings Home. Select the Shortcuts tab and then select the Custom Shortcuts menu option.

Now click the + button and select a name (arbitrary - "toggle touchpad" and a the command = /usr/bin/toggle_touchpad.sh)

This assumes you've copied one of the above shell scripts, created it, copied it (or soft-linked it) into /usr/bin, named it toggle_touchpad.sh and made it executable (chmod +x toggle_touchpad.sh)

Now select the new shortcut you've created and select the key combination you want to associate with it (on Dell if you select Fn + F5 the shortcut is actually called Touchpad toggle.) The shortcut will change from disabled to Touchpad Toggle.

share|improve this answer

I have an E6510, with 12.04. The ALPS touchpad works out of the box with two finger scrolling. It does not do palm detection or disable while typing.

I use "touchpad-indicator" to disable the touchpad when a mouse is hooked up.

share|improve this answer

To take the first answer a little farther...

I created a script to toggle the touchpad on and off using the xinput command from above. Then went into keyboard shortcuts (Mandriva) and added a custom command. Now the "Super+T" key turns on and off my touchpad. It's still manual, but I don't have to have a mouse connected to toggle it!

share|improve this answer

These settings can be configured in your Control Panel > Mouse Properties. If you don't see the Dell Touchpad tab, you need to download this mouse driver from Dell.

It took me a while to figure this out too. My system is a Latitude E5510 with Windows 7 installed. Good luck!

Ha, I found this question after doing a quick Google search for the general. I'm realizing now you're probably not running Windows. Oops!

share|improve this answer
    
Thanks for confirming that the disabling works on Windows :). The trackstick could remain enabled, while the touchpad is disabled, right? –  Ivo Danihelka Nov 27 '10 at 11:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.