Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 12.04 and Thunderbird 12.0.1 from scratch but I hear no sound when new mail arrives.

I have installed pulseaudio-esound-compat and esound-common but the problem persist.

How can I fix this, and get new mail notification sounds in Thunderbird?


Bug reported here: https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/1009108

share|improve this question
    
+1 I have this same problem, new since a fresh install of 12.04. Strangely, the little 'pop' sound when changing volume is back after disappearing in 11.10. Can't have everything I guess... –  Tom Brossman Jun 2 '12 at 14:39
    
Although others confirm this problem, it does not seem to exist always: I can't reproduce this problem. A fresh 12.04 with thunderird and I can hear the sound. I did not change anything with thunderbird, but I use the old .thunderbird directory. I use GNOME shell instead of Unity, but can't believe this matters. –  lumbric Jun 3 '12 at 10:25
    
In addition to continuing to seek workarounds here, I recommend reporting this as a bug. –  Eliah Kagan Jun 6 '12 at 18:17
add comment

7 Answers

I was having a similar issue in Ubuntu 12.04 with Thunderbird 12.0.1. At least in my case, the origin of the problem was two-fold:

  1. the option "Default system sound for new mail" works only if sound effects are enabled in Ubuntu. If you want Thunderbird to play the default system sound from the Ubuntu theme, but do not want to enable the sound effects, just provide this path /usr/share/sounds/ubuntu/stereo/message.ogg in the option "Use the following sound file".

  2. whenever you change the path to the sound file, it is crucial to restart Thunderbird, otherwise it plays no sound at all.

My suggestion is therefore to select the sound file manually and restart Thunderbird. If it still doesn't work, I think you should file a bug report in launchpad, see here how. This might be a possible duplicate of this very old bug.

Note that the "Choose sound" menu has an hard-coded filter for wav files. In order to select an ogg file you'll have to specify the location explicitly by clicking on the pencil icon and providing the sound file location.

enter image description here

share|improve this answer
    
Just tried #1 but Thunderbird will only let me choose a WAV file. –  Tom Brossman Jun 6 '12 at 15:51
    
Yeah, I know, yet another bug. Still you can provide the path to sound file explicitly. I have added a snapshot to show this. –  aroque Jun 6 '12 at 18:11
add comment
up vote 1 down vote accepted

From Thunderbird v12, it uses libcanberra. And the canberra system only plays the sounds if sound effects are enabled: For default sound and for a custom sound.
IMHO this behavior is incorrect but this is what Mozilla have decided.

You can install libcanberra from the Software Center Install libcanberra-gstreamer, or by opening a Terminal window (Ctrl+Alt+T) and running these commands:

sudo apt-get update
sudo apt-get install libcanberra-gstreamer
share|improve this answer
add comment

As for the home folder question, it is a matter of white space. In my situation (plain up to date Ubuntu 12.04, Thunderbird 13.0.1), a notification wav sound does not work if either the path (like My Music), either the file name (like You’ve got mail.wav) contains a space. It does work otherwise (not only from the home folder). Before trying every esound, pulseaudio, libcanberra or whatever, make sure the path and file name contain no space.

share|improve this answer
add comment

I had the same problem but got it sorted by doing this: install esound in synaptic then move your sound file you want Thunderbird to play in to your home folder (not in any folder just direct in to home folder) then start Thunderbird and go to preferences and browse for your sound file in your home folder. That worked for me.

Hope that was helpful for you

Cheers Patrick

share|improve this answer
    
It doesn't work. :-( –  Simón Jun 2 '12 at 14:22
add comment

Download and install Thunderbird 14 from here: Install Thunderbird 14

All notification sounds work. Not all add ons will be compatible but will be in time.

share|improve this answer
add comment

I solved by installing this package: libesd0.

sudo apt-get install libesd0
share|improve this answer
add comment

In my case the problem was not triggered by missing packages nor by missing Thunderbird configuration parameters nor by ogg oder wav problems, the only thing I had to do to solve my issue was:

Ubuntu Menu (top right) --> System Settings --> Hardware: Sound --> Sound Effects --> Alert Volume --> Slide full to right (100%)

Then Thunderbird began to play wonderful notification sounds when new mails arrived. Hope this helps some of You, too.

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.