Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using the "WP super cache" WordPress plugin on a Ubuntu 12.04 server and found it is incompatible with php APC.

After installing and activating the WordPress plugin, the blog was down and users were getting a error page:

HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfil the request.

I noticed a segmentation fault in the Apache error log (/var/log/apache2/error.log).

In the troubleshooting section of the WP super cache FAQ I noticed a description of my problem:

  1. The "white screen of death" or a blank page when you visit your site is almost always caused by a PHP error but it may also be caused by APC. Disable that PHP extension if you have trouble and replace with eAccelerator or Xcache.

So I commented out the apc Apache extension and restarted Apache:

> sudo emacs /etc/php5/apache2/conf.d/apc.ini 
;extension=apc.so
> sudo service apache2 restart

Sure enough, that fixed the problem - the blog was back up and caching enabled.

The thing is, I actually want APC cache to run as well. The opcode cache is useful. I know I could use another opcode cache but does anyone know a APC setting I can change to allow this plugin to work with APC?


Note: I also tried Ubuntu 10.10, 11.04, 11.10 and had exactly the same issue.

share|improve this question
1  
I have been able to run both WP Super Cache and APC in an Nginx environment. Not sure how that would differ from Apache though. –  Marco Ceppi Jun 5 '12 at 17:46
add comment

1 Answer

Been looking around for some more technical explanation of this.

I don't believe this problem is Ubuntu related. I've seen similar Wordpress WSOD crashes... APC, WP Supercache, Apache, FreeBSD. Site(s) would run reliably for some period of time then WSOD all of a sudden.

Apache restart (which would flush APC cache in memory) fixed the issue.

Turning off SuperCache fixes the issue.

SuperCache probably has some obscure bug with APC...character encoding bug?

share|improve this answer
    
Fore reference, here is a similar question on FreeBSD (with no better answer): wordpress.stackexchange.com/questions/19963/… Also we are running on OSX ourselves and will unfortuntely have to uninstall SuperCache –  PowerKiKi Sep 25 '12 at 0:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.