Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A previous question having yielded no conclusive results, so i would like to know if is possible to move up the time when the Network Manager starts to be earlier in the boot process, since it takes so much time to load once i am connected. It should be ready by the time I reach the login screen, without the stupid 15 second delay I keep experiencing every time I log in!

For more information on my problem, see this question

share|improve this question

I have three ideas:

You may have a

  1. legitimate bug.

    The network manager is normally ready long before the login screen. On my machines, it already establishes connections when there isn't even anything on the screen.

    Now, the bug is very probably one in the specific driver you are using. I.e., as suggested in your first question, the driver not being ready before the log in.

  2. Problem with your keyring.

    The Keyfiles: Error: [Errno 2] No such file or directory ProcEnviron in your Bug report leads me to believe that there may be somthing wrong.

    But this is quite hard to diagnose with the available information. Perhaps you should have a look at this bug report.

  3. A hardware switch set to off.

    Ubuntu has to manually switch on the power to your wireless adapter, which happens late. (Note, this is not a statement of fact, it's a wild guess; I've no idea why it would or if it does happen late)

    Okay, this one is really far fetched, but it's worth a try. If your notebook has a physical switch for the wireless network, make sure it is set correctly. Mine has one, and it's really hard to see what it's set to. Here's some random examples from the web:

alt text

even worse:

alt text

Rather tricky to spot when these are set incorrectly. In some cases, those switches may not completely disable the wireless adapter, which could possibly explain your problem.

share|improve this answer
I think it's either 1 or 2. However, my wireless worked perfectly with Lucid Lynx before. – Lyrositor Nov 20 '10 at 15:59

Did you check "Available to all users" in Network Manager? Checking it solved this problem for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.