Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed fresh a Ubuntu system on my computer but then it does not show the NTFS partitions, DVD-ROM and flash drive.

I have two HDD's. One is primary SATA (80 GB) and other is slave, an old IDE (40 GB). Neither shows up. What can I do to solve this problem?

Ubuntu 10.04 works fine but not this one.

share|improve this question
add comment

2 Answers 2

Sometimes it is possible that in BIOS you must have changed the setting for your hdd try changing the SATA mode from IDE to AHCI. For dvd-rom check in hardware whether it is connected to master or not.

share|improve this answer
add comment

I learned this the hard way. Ubuntu needs all disks to be set to the third option, cable select. I had to set all my disks as cable select to get everything to load up correctly.

share|improve this answer
2  
I have an Ubuntu system with IDE disks that are jumpered manually to master and slave, rather than using cable select. I have not had any problems. Can you provide any corroborating sources for this? And if so, has a bug been reported? On the other hand, if you have a single IDE drive, it must either be jumpered as primary or as cable select; not as slave. If that's what you mean, you may want to edit your answer to indicate this ...as that would probably be good advice. But that wouldn't explain how a previous version of Ubuntu worked. –  Eliah Kagan Jun 15 '12 at 9:55
1  
I have never had to use Cable Select. –  hexafraction Jul 16 '12 at 18:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.