Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running i3-wm under a gnome session in 12.04.

Nautilus is not normally running.

I regularly loop-mount ISO and other filesystem image files, and every time I do this nautilus pops up both a desktop window and a window opened at the new mount point.

Uninstalling nautilus is not an option -- I tried this, but apt reports that dozens of packages depend on it (directly and indirectly).

This question is similar, but only talks about preventing launching on USB stick insertion. I don't want nautilus to run, ever -- removal would be ok with me if it didn't require uninstalling the world.

share|improve this question
add comment

3 Answers 3

What I did was create an executable script to open nautilus for me

sudo nano /usr/bin/nfm

cut and paste this in

#!/bin/bash
nautilus  --browser --no-desktop &

Finally make it executable

sudo chmod +x /usr/bin/nfm

In your i3 config file wherever you put it make sure you run this:

# nautilus as a daemon!
nautilus --no-default-window --no-desktop &
share|improve this answer
    
How does this prevent nautilus from being run? Did you even read the question? –  Benubird Dec 11 '12 at 9:17
add comment

You can disable the permission to execute nautilus like this in terminal:

sudo chmod a-x /usr/bin/nautilus
share|improve this answer
add comment

Try to disable automount with the dconf editor. You can find a good tutorial right here.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.