Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got movies playing in fast forward in YouTube HTML 5 mode if I play it in Google Chrome. If I open it with Firefox, it plays well. Any ideas?

share|improve this question

4 Answers 4

up vote 63 down vote accepted

If you're using Chrome from the dev or unstable channels, you probably have a bad Flash plugin enabled (this affects HTML5 audio as well for some obscure reason).

To fix it, go to chrome://plugins and disable all the flash plugins. Then click +Details to show the individual versions of Flash, enable them one at a time until the problem goes away.

This is the configuration that worked for me:

flash plugin configuration in chrome

If you none of the versions you have work, you may need to install the adobe-flashplugin package:

sudo apt-get install adobe-flashplugin
share|improve this answer
    
Sadly if you only have the NPAPI version enabled most websites seem to think you don't have flash at all! –  Timmmm Jul 24 '12 at 21:05
1  
Yes, disabling of Shockwave Flash 11.3 r31 helped me. The only difference is that I'm using OpenSUSE 12.1 distro. –  George Gaál Jul 24 '12 at 23:30

Please note: sometimes if the problem still persists then this may be related to pulseaudio, in such case you can use

killall pulseaudio

pulseaudio would start automatically again

And restart the browser and it will work.

If this only works temporarily, you can try replacing pulse audio with the alsa module for good.

share|improve this answer
2  
This is the only solution that worked for me. Strange thing was that using Jacob's solution gave me either a really fast youtube or a really stuttery and slow one. –  ubershmekel Aug 15 '12 at 7:35
1  
Same as ubershmekel here. Selecting a specific flash plugin made it either very slow or even faster. Leaving the plugins as they were and just killing and starting pulseaudio did the trick. Note: sudo service pulseaudio restart did NOT help. –  nem75 Aug 30 '12 at 22:36
6  
You shouldn't need to explicitly restart it. It should start automatically as needed when not running.. –  Timo Lehto Sep 4 '12 at 6:48
    
The problem just came back after a long hiatus. Any idea for a permanent fix? –  ubershmekel Nov 8 '12 at 6:55
    
just killing worked for me. It seems it restarts itself –  serengeti12 Dec 3 '12 at 16:23

I found some solutions:

  • Reset you're sound settings, (apparantly if you use hdmi for audio and video there is nothing slowing the playback down) so what you have to do is try changing audio playback device :)

  • One user found that "setting the specific speaker layout fixed my problem (from nothing to 5.1, as that is what I have)."

share|improve this answer
    
Here I am a year and a half later to find out that HDMI audio does screw up the playback. Is there a fix for this? –  Lunyx Jan 5 at 15:18

For me it was related to an install of Totem video player which installed a vlc multimedia plugin for chrome:

VLC Multimedia Plugin (compatible Totem 3.0.1)

Disabling this plugin made it work!

share|improve this answer

protected by Community Jul 24 '12 at 8:38

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.