Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Currently on my laptop I have Win7, Win8(Consumer Preview), and Ubuntu 12.04. I am having a problem booting Win7

When I boot the computer the first screen I get is the GRUB boot manager screen which has menu entries for Ubuntu and Windows 8. If I want to boot into Windows 7 I have to select the Windows 8 loader and then select Windoes 7 from the windows boot menu.

Due to the Win8 loader being a little silly it then reboots the pc in order to load Win7, however it just takes me back to the GRUB2 and I have to select the Win8 loader again and then Win7 will boot. This is faily long winded and unecessary.

I would much prefer it if I could just add Windows 7 to the GRUB menu and select it from there rather than boot Windows 8, select Windows 7, and reboot again.

My only concern being that Windows 8 has removed/replaced the Win7 bootloader.

Has anyone come across this problem?

share|improve this question
    
Could we get a status update? Are things copacetic again? –  irrational John Jun 3 '12 at 3:25
    
Sorry for the late reply. I eventually gave up. When selecting windows 7 from my GRUB list it can't find the partition and if I select Windows 8 it boots Windows 7. Haven't really had any need to go into 8 so haven't bothered to fix it. –  Jacob Tomlinson Aug 1 '12 at 13:53
add comment

3 Answers

create entry in 40_custom(don't remove anything) in directory /etc/grub.d

gksudo gedit /etc/grub.d/40_custom 

add an entry like this

menuentry "Windows 7" {
    set root=(hd0,3)
    chainloader +1
}

Modify the set root value of course. Determine the hdd by typing: sudo fdisk -l . For example, /dev/sda1 is (hd0,1) if its on the second HDD: /dev/sdb1 >> (hd1,1)..and so on. You can understand the syntax from this I guess. After you made the modifications, do sudo update-grub and you can try to boot it. BTW grub actually can't boot windows the only thing it can do is to chainload(to call) windows bootloader.

share|improve this answer
    
I'm afraid this didn't work. It appears Win8 has totally replaced the Win7 bootloader and so there is only GRUB2 and Win8 loader on my system. –  Jacob Tomlinson May 25 '12 at 11:54
    
@killfall as I've already mentioned in answer you can not boot in windows by just hitting on the grub(or grub2) menu. Then you need to select which version of windows you want to boot into. –  virpara May 25 '12 at 15:26
    
If I select the Windows 7 partition I just get 'MBR nto found'. My original hope was that Windows 8 was chainloading windows 7 and so I could tell GRUB2 to do the same. But I can't find a windows 7 bootloader on any of the partitions, only the windows 8 one which requires the reboot. –  Jacob Tomlinson May 28 '12 at 14:55
add comment

In the W8 loader, go to the options, and change the default boot to W7. Then boot into W7 once and reboot. Then your grub install should be able to see both. Worked for me.

share|improve this answer
    
I have tried this but now I don't get the option to boot Win8, it just boots 7 if I select 8 from the GRUB2 menu. –  Jacob Tomlinson May 25 '12 at 11:55
    
Can you post your entire GRUB config in your question please. I'll compare it to mine. –  Frantumn May 25 '12 at 12:53
    
I'll update it when I get home –  Jacob Tomlinson May 25 '12 at 13:07
    
also check this out –  Frantumn May 25 '12 at 13:19
add comment

I have no idea what is going on with Windows 8. I installed a virtual machine with the three operating systems as you described and the exact same thing happened. It should not happen. I can not explain why it happens. But it did.

The way I was able to change this behavior (in my VM) was by installing EasyBCD (in Windows 7) and then doing an update/save of the Windows boot menu. (See screenshot below.)

image of EasyBCD "Edit Boot Menu" window with "Save Settings" circled

In my case merely "updating" the Windows Boot Menu with EasyBCD ... even without changing anything in the menu ... removed the Windows 8 menu and weirdness. After I did this when I selected the Windows 8 entry in the GRUB boot menu, the old style of the Windows boot menu shown in the screenshot below is displayed. And selecting Windows 7 now starts Win 7 directly without a reboot back to GRUB.

screenshot of text graphics Windows boot menu

share|improve this answer
    
I can see this being an option, it would still require me to select the Win8 bootloader from the GRUB2 menu and then select a Win OS from there but I guess it wouldn't involve the rebooting weirdness. –  Jacob Tomlinson May 25 '12 at 11:56
    
I am afraid you cannot boot Windows 7 directly in your case. GRUB can only chainload the Windows boot loader which is why you get the Windows boot menu. Once you press enter on Windows 8 in GRUB, it's all in the hands of Windows. But hopefully you can get rid of that bizarre reboot back through GRUB before you can boot Windows 7. I mean WTF is up with that??? –  irrational John May 25 '12 at 12:20
    
Yeah I knew that was the case, I was just hoping that the windows 8 loader was chainloading windows 7 so I could just get GRUB to do it instead. –  Jacob Tomlinson May 25 '12 at 13:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.