Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have recently installed Ubuntu and I'm having problems with my (RTL8190) card.

I followed the steps listed here - Ubuntu Help: Troubleshooting Wireless. After using the command sudo lshw -C network I got the following output:

description: Ethernet interface
product: RTL8111/8168B PCI Express Gigabit Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:03:00.0
logical name: eth0
version: 06
serial: 10:78:d2:73:9f:0d
size: 10Mbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168e-2.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
resources: irq:42 ioport:d800(size=256) memory:f8fff000-f8ffffff memory:f8ff8000-f8ffbfff

*-network UNCLAIMED
description: Network controller
product: RTL8190 802.11n Wireless LAN
vendor: Realtek Semiconductor Co., Ltd.
physical id: 1
bus info: pci@0000:04:01.0
version: 00
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list
configuration: latency=64 maxlatency=64 mingnt=32
resources: ioport:e800(size=256) memory:fbfff000-fbffffff

I proceeded to install the ndisgtk package and downloaded the net819xp.inf driver.

Using the windows wireless drivers app, I selected the .inf file but it said there was an error. I attempted to select it again but it said it was already installed. When I run the original command again it still lists the card as UNCLAIMED.

Anyone know how to get it working?

share|improve this question

1 Answer 1

Try to download the sources for the network card from realtek. I have these:

r8168-8.029.00 (maybe from here realtek r8168-8.029.00; can't remember exactly. I cherish the sources I have on my machine... :-)

And then follow instructions in this post:

RTL8111/RTL8168 fix

It's great. The Realteks are never working out of the box.. for years. At least, not for me. I always need a fix. So, I fixed it again after installing 12.04.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.