Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Note:

This is an attempt to create a canonical question that covers all instances of "low-graphics mode" error that occurs to a user, including but not limited to installation of wrong drivers, incorrect or invalid lightdm greeters, low disk space, incorrect installation of graphics card like ATI and Nvidia, incorrect configuration of xorg.conf file while setting up multiple monitors among others.

If you are experiencing the "low-graphics mode" error when trying to login but none of the following answers work for you, please do ask a new question and then update the answers of this canonical question as and when your new question gets answered.


When I try to boot into my computer, I am getting this error:

The system is running in low-graphics mode

Your screen, graphics cards, and input device settings could not be detected correctly. You will need to configure these yourself.

fail-safe X mode

How do I fix the failsafe X mode and login into my computer?


Answer index:

share|improve this question
    
What happens when the message you see here is almost impossible to read? And I can forget about being able to see the terminal in the Ctrl-Alt-F1 trick. – Adrian Keister Jun 6 '13 at 16:23
    
I tried to add to the master question but apparently am too much of a newb to be useful. – peejaybee Sep 29 '13 at 0:26
    
ok i tried everything on this page, but the fix for me was to make some more room. "df -h" showed sda1 as 100% so then i run "du / | sort -g" and found trash was like 30gig... 80% of harddrive, so i did "rm -fr ~/user/.blah/trash" and followed up with another df -h showing 14%, so a final reboot and i was back in. – scott Jan 18 '14 at 6:24
    
@Braiam I realize this is old, but... this question is protected. It's pretty obviously visible. – nyuszika7h Mar 15 '15 at 0:17
    
I had the same problem but i fixed it from this link thegeekyland.blogspot.com/2014/07/ubuntu-1404-lenovo-g510.html – Arlind Aug 2 '15 at 8:01

40 Answers 40

I fixed this problem by creating a new xorg.conf file (copying the text from xorg.conf.failsafe).

Details: http://askubuntu.com/a/296217/55223

share|improve this answer

I had the “The system is running in low-graphics mode” error after trying to upgrade my Acer Aspire 4810T with Intel GM45 Express Chipset graphics from a 64bit 13.04 to a 64bit 13.10.

I had less than 2 gigabytes of free disk space when I started the upgrade. I faced first anomalies already before the reboot. The upgrade window showing the progress showed that everything has been downloaded and installed but it never closed. Couldn't close it even manually.

Then, after reboot, I got the “The system is running in low-graphics mode” error window.

I tried to solve the problem as proposed above by Luis Alvarado, user41938, community wiki, Azul Mascara and David M. Sousa.

My guess is that my problem was related to tiny disk space as hinted by Azul Mascara. But just freeing disk space and even allocating more by repartitioning didn't help.

After struggling more than enough with the problem I decided to download the 13.10 64bit and make a bootable USB stick with it. I booted the laptop with the USB stick and selected the installation on top of the old 13.10 (non-functioning) system that the installer recognized. This fixed my problem.

share|improve this answer

I had the same problem but this method works for me.

When you get The system is running low-graphics mode error,press ctrl+alt+F1 ,it will take you to the console.
Then it will asks for username and passwordto login,give that.Once you logged in to the console run the below command,

sudo rm /etc/X11/xorg.conf
sudo service lightdm restart

It will get you back to the GUI login.Why this problem occurs means,after you installed graphics drivers,it creates xorg.conf file in /etc/X11 folder.Which prevents the system from GUI login.

share|improve this answer

First, type the following commands:

$ lspci | grep -i VGA
$ lspci | grep -i amd

For me (HP pavilion 15n003tx, Saucy), the outputs were:

test@HP-Pavilion-15:/etc/X11$ lspci | grep -i VGA
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
test@HP-Pavilion-15:/etc/X11$ lspci | grep -i amd
0a:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M]

Since the AMD device doesn't come as output in the first command, even if you install amd drivers, you'll probably end up with the following error in /var/log/Xorg.0.log:

[    12.873] (II) fglrx(0): Invalid ATI BIOS from int10, the adapter is not VGA-enabled

Hence, I followed the steps:

test@HP-Pavilion-15:/etc/X11$ sudo apt-get purge fglrx*
test@HP-Pavilion-15:/etc/X11$ cp /etc/Xorg/xorg.conf.failsafe /etc/xorg.conf

The contents of xorg.conf.failsafe are:

Section "Device"
    Identifier  "Configured Video Device"
    Driver      "fbdev"
EndSection

Section "Monitor"
    Identifier  "Configured Monitor"
EndSection

Section "Screen"
    Identifier  "Default Screen"
    Monitor     "Configured Monitor"
    Device      "Configured Video Device"
EndSection
share|improve this answer

I fixed this problem by removing /var/lib/lightdm/.Xauthority manually.

You can also try deleting the file ~/.Xauthority and rebooting.

share|improve this answer

I have the same problem (The system is running in low-graphics mode) when I reboot the system connected to an Oculus Rift (1080x1920 monitor). If I reboot the machine and connect a monitor of (1920x1080 resolution) it works ok.

The machine has Ubuntu 14.04 and Nvidia 970, driver 346 and kernel 3.15. With the default lightdm configuration (autologin activated).

The problem started suddenly, without making major changes in Ubuntu configuration.

I had the same issue in another machine with nvidia 970, same version of Ubuntu / different kernel. On this machine the problem happened when changing from autologin to login with user/pw in lightm and it was solved rebooting the machine with a 1920x1080 monitor connected and enabling autologin again.

share|improve this answer

For me this problem occurred after upgrading from "Ubuntu 12.04 LTS" plus TDE to "Ubuntu 14.04 LTS" plus TDE. TDE is the trinity desktop environment (trinitydesktop.org). The cause of the error was that

  1. /etc/X11/default-display-manager pointed to lightdm although during the upgrade I told it to use tdm-trinity as default.
  2. lightdm was broken (and I don't care why).

The fix was to run dpkg-reconfigure tdm-trinity and to choose tdm-trinity as my default. A few days later the problem came back and again /etc/X11/default-display-manager pointed to lightdm, don't know why.

share|improve this answer

This one worked for me using ubuntu 13.10, my ubuntu stopped working after installing opencv.

sudo apt-get purge nvidia-304 nvidia-current nvidia-libopencl1-304 nvidia-settings 

Just purge all the nvidia-* and restart

I am not a geek just a layman don't know the reason why it works.

share|improve this answer

Different users solved their in different ways (since the causes of the problem were different for different people). I am describing what caused the problem in my desktop and how did I solve it.

WARNING: My method will work on your computer only if the cause of the problem is the same. Nevertheless read my reply to develop a general understanding.

Cause of the problem:

I made some changes to the file

/etc/lightdm/lightdm.conf

After I rebooted I encountered the 'system-is-running-in-low-graphics-mode' error. Clearly the changes made to the above 'lightdm.conf' file needed to be undone.

How did I solve it:

  1. When the error message appears, press Ctrl+Alt+F1, then login using your ubuntu username and password.

  2. Go to the directory /etc/lightdm/ (cd /etc/lightdm/). Open the above file in vim using vim lightdm.conf. Vim opens the file in the terminal itself.

  3. Undo the changes that caused the problem. In my case I removed a line that I had added (which caused the problem). Save and quit vim. Following this step requires you to know how to use vim editor to edit files. If you are unfamiliar with vim watch tutorials on how to open a file, edit a file, save and quit a file in vim.

  4. Reboot the computer. The problem is gone!

PS: I undid the change that caused the error. Your cause of error could be completely different from mine. So, blindly following my answer definitely won't help. On the other hand it may damage your computer.

share|improve this answer

Go to System, Administration and click on Hardware drivers (in Maverick it is called Additional Drivers). It will search for and allow you to install the proper graphics driver which should allow you to run in higher res.

In Linux there are two ways to do most things, by the GUI or by the terminal. This is easier for most people used to a graphical user interface. The second GUI way to do it would be to go to Software Center or Synaptic and install the packages in the previous post. Search for them in the search bar. I don't think that Ubuntu has used xorg.conf for awhile, so it would not help to look for it.

share|improve this answer

protected by Community Oct 19 '12 at 11:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.