Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Note:

This is an attempt to create a canonical question that covers all instances of "low-graphics mode" error that occurs to a user, including but not limited to installation of wrong drivers, incorrect or invalid lightdm greeters, low disk space, incorrect installation of graphics card like ATI and Nvidia, incorrect configuration of xorg.conf file while setting up multiple monitors among others.

If you are experiencing the "low-graphics mode" error when trying to login but none of the following answers work for you, please do ask a new question and then update the answers of this canonical question as and when your new question gets answered.


When I try to boot into my computer, I am getting this error:

The system is running in low-graphics mode

Your screen, graphics cards, and input device settings could not be detected correctly. You will need to configure these yourself.

fail-safe X mode

How do I fix the failsafe X mode and login into my computer?


Answer index:

share|improve this question
show 4 more comments

36 Answers

Will try to answer the ones I can:

Assuming the answer by Jokerdino was already checked: The greeter is invalid

Issues with Nvidia or AMD/ATI graphics

This happens when a driver has a problem installing correctly (Most cases). For this do the following:

  1. Boot PC leaving SHIFT pressed to make the GRUB Menu show.

    Grub menu

  2. Select Recovery Mode which will continue booting correctly until the Recovery Menu appeares.

  3. Select from the recovery menu failsafeX.

    recovery menu, yes it's german please replace :( wasn't able to get it in english by changing system language and doing update-grub

  4. In some cases failsafeX will load fine (You lucky dog), for others (Me) it will give an error along the lines of "The system is running in low-graphics mode" and will stay there forever. When this happens, press CTRL+ALT+F1 to go to the terminal. Type in your Username and Password.

    low graphics mode error message

  5. Reinstall the drivers depending on your case:

    • Nvidia

      sudo apt-get install nvidia-current - More stable/tested version sudo apt-get install nvidia-current-updates - More up-to-date version

      For other cases see this answer for details and follow the links there to help you along the way.

    • AMD/ATI

      The simple way is to sudo apt-get install fglrx. If this does not work keep reading.

      Go to AMDs support site and download the driver you need. (If you have a newer card, you may want to download be the latest beta driver instead of the stable one. You would need to compare release dates and read through release notes to find out which driver version supports which chips.) Put the downloaded driver in some folder and rename it to "amd-gpu.run" to simplify name. Go to the folder where you downloaded the file and type chmod +x amd-gpu.run to give it Executable Permission. Now just simply run ./sh amd-gpu.run and follow the onscreen steps.

      After rebooting all problems should be solved. If you test 'Additional Drivers' with a problem like this it will finish downloading the package but then it will give an error. It also gives the same error if you use 'Software Center' and 'Synaptic'. The only way was to go to the failsafeX option and do the workaround about changing to the tty1 terminal and doing it via command line.

Note that if the problem occured after installing an unsupported driver from the amd site then you may have to first delete the driver you had installed. For this, run in the tty session (i.e) in the terminal screen you get after pressing CTRL+ALT+F1 :

sudo aticonfig --uninstall

(If this command didnt work then check this site . Look under the "Uninstalling the AMD Catalyst™ Proprietary Driver" heading.) After doing this, you may reboot with the command :

sudo shutdown -r now

Now you must get back access to the Unity desktop(Of course with the AMD driver uninstalled). Then you can get to this site which clearly helps in choosing the right AMD driver for your System specifications. Also read the release notes for the latest driver for your graphic card(Especially check if your system satisfies all the system requirements). Then after downloading your driver installer(the .zip file) get to this site and follow the instructions to install your driver. Your driver must be installed and it should work successfully.

I also need to add that I do not recommend downloading the Drivers from the Nvidia site since they:

 * Might create additional problems with Ubuntu
 * Are not updated automatically
 * Are not tested thoroughly in Ubuntu

Always use the nvidia-current package or the nvidia-current-updates one. These are tested and approved already for the Ubuntu version you are using and will give less errors and incompatibility bugs.

Issues with Intel graphics

For Intel it is recommended to do the following after doing all the steps mentioned above but before installing anything (When you are in the Terminal). You can choose from the Xorg-Edgers which is an Unstable PPA or the X-Swat which is more stable:

Warning: This PPA is very unstable for some things. So do it with that in mind.
sudo add-apt-repository ppa:xorg-edgers/ppa -y

or X-Swat:
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates -y

After that sudo apt-get update and you should receive several updates. X-Swat currently does not have Intel drivers in the latest versions of Ubuntu.


Update log

UPDATE 1: Added this extensive answer to solve many of the problems that might end with the error mentioned here: Installing Nvidia Drivers

UPDATE 2: AMD is no longer releasing (stable) graphics drivers on a monthly basis and not all graphics chips are supported by their Linux drivers upon product release. At the time of this update the latest stable driver is almost 5 months older than the latest beta driver. You should look at the release notes to check if there is a driver that supports your graphics chip and the software versions you are using (X.org xserver or Mir).


Like always please test and give feedback so I can enhance my answer since others will be also reading it. The better it is, the more people it will help.

share|improve this answer
1  
After trying all the other solutions, that's the one that worked for me. Thanks! –  Matthieu Mar 21 '13 at 22:34
show 6 more comments

First, type the following commands:

$ lspci | grep -i VGA
$ lspci | grep -i amd

For me (HP pavilion 15n003tx, Saucy), the outputs were:

test@HP-Pavilion-15:/etc/X11$ lspci | grep -i VGA
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
test@HP-Pavilion-15:/etc/X11$ lspci | grep -i amd
0a:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M]

Since the AMD device doesn't come as output in the first command, even if you install amd drivers, you'll probably end up with the following error in /var/log/Xorg.0.log:

[    12.873] (II) fglrx(0): Invalid ATI BIOS from int10, the adapter is not VGA-enabled

Hence, I followed the steps:

test@HP-Pavilion-15:/etc/X11$ sudo apt-get purge fglrx*
test@HP-Pavilion-15:/etc/X11$ cp /etc/Xorg/xorg.conf.failsafe /etc/xorg.conf

The contents of xorg.conf.failsafe are:

Section "Device"
    Identifier  "Configured Video Device"
    Driver      "fbdev"
EndSection

Section "Monitor"
    Identifier  "Configured Monitor"
EndSection

Section "Screen"
    Identifier  "Default Screen"
    Monitor     "Configured Monitor"
    Device      "Configured Video Device"
EndSection
share|improve this answer
add comment

Or, the most likely of the reasons with old PC's is:

Your graphic card just do not support unity.

Try Lubuntu/Xubuntu instead.

Unity requires: Any graphics card with OpenGL 1.4 support (All GPUs released today by either NVidia, AMD or Intel; GPUs released by NVidia and AMD over the last 5 years; GPUs released by Intel after the GMA 950). If you card don't meet this requirements, then is just that you can't use Unity (yet).

share|improve this answer
add comment

I had the same problem but this method works for me.

When you get The system is running low-graphics mode error,press ctrl+alt+F1 ,it will take you to the console.
Then it will asks for username and passwordto login,give that.Once you logged in to the console run the below command,

sudo rm /etc/X11/xorg.conf
sudo service lightdm restart

It will get you back to the GUI login.Why this problem occurs means,after you installed graphics drivers,it creates xorg.conf file in /etc/X11 folder.Which prevents the system from GUI login.

share|improve this answer
add comment

I had the “The system is running in low-graphics mode” error after trying to upgrade my Acer Aspire 4810T with Intel GM45 Express Chipset graphics from a 64bit 13.04 to a 64bit 13.10.

I had less than 2 gigabytes of free disk space when I started the upgrade. I faced first anomalies already before the reboot. The upgrade window showing the progress showed that everything has been downloaded and installed but it never closed. Couldn't close it even manually.

Then, after reboot, I got the “The system is running in low-graphics mode” error window.

I tried to solve the problem as proposed above by Luis Alvarado, user41938, community wiki, Azul Mascara and David M. Sousa.

My guess is that my problem was related to tiny disk space as hinted by Azul Mascara. But just freeing disk space and even allocating more by repartitioning didn't help.

After struggling more than enough with the problem I decided to download the 13.10 64bit and make a bootable USB stick with it. I booted the laptop with the USB stick and selected the installation on top of the old 13.10 (non-functioning) system that the installer recognized. This fixed my problem.

share|improve this answer
add comment

I just had to disable Internal Graphics Board on BIOS display.

Using ga-z87n/ga-h87n (GIGABYTE) motherboard.

share|improve this answer
add comment

Install gdm Install gdm. GDM provides the equivalent of a "login:" prompt for X displays: it asks for a login and starts X sessions.

During the installation of gdm you will be asked to select either gdm or lightdm as the default login display manager. Select gdm.

By the way, the fact that you have this problem on 2 different computers is a sign that there may be an irregular voltage to your computer power supply. To test for this possibility take one computer to a different address and try booting it there.

share|improve this answer
add comment

I fixed this problem by removing /var/lib/lightdm/.Xauthority manually.

share|improve this answer
add comment

It is not related to Nvidia drivers. Because by default Ubuntu uses non-Nvidia drivers even though you might have Nvidia GPUs. I have an Nvidia GPU too.

My Ubuntu used to boot fine until something happened which caused the same issue. After reading posts, reading logs and little bit trial and error, turns out the problem is related to lightdm GUI server.

I don't know solution to the problem but there is a quick work around in 3 steps. This will save you from reinstalling Ubuntu.

  1. When the error shows up, hit Ctrl+Alt+F1. This will open the command line interface. Login as root.

  2. Remove a particular X11 config file. This file is not really required.

    rm /etc/X11/xorg.conf.failsafe
    

    Somehow, the existence of the above X11 configuration file causes the OS to throw that error.

  3. Restart lightdm GUI server.

    service lightdm restart
    

This will restart the lightdm GUI server and voila your desktop is back!

share|improve this answer
add comment

Let's assume, arrogantly, that it is a problem with your X display manager.

Enter the terminal (you can use a virtual console if you cannot use a graphical terminal window), the one you said that you have access to, and enter the following:

sudo apt-get install gdm

. . . and choose gdm.

Then type:

sudo service gdm restart

(Or ... start instead of restart.)

According to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1070150 this is a way to workaround a bug with lightdm.

Before typing that, you may need to first stop the other display manager that is running. This is usually LightDM:

sudo service lightdm stop

If you have trouble getting GDM to start, and this is an installed system rather than a live environment, then you can just reboot and it will start automatically because you configured it as the default display manager. (You should be able to shut down and restart normally. Otherwise, one way to reboot if the GUI is not working properly is to press Ctrl+Alt+Delete while on a virtual console.)

share|improve this answer
add comment

I fixed this problem by creating a new xorg.conf file (copying the text from xorg.conf.failsafe).

Details: http://askubuntu.com/a/296217/55223

share|improve this answer
add comment

Phenomenon: I first saw Booting without full network configuration message that never ended. After Action-1 below, I faced The system is running in low-graphics mode issue.

Action-1: Force to shutdown the machine (by keeping power button pressed as normal). Choose recovery boot.

Effective solution: Remove & install xserver-xorg, inspired by this thread.


Edit) after creating xorg.conf and had it read in xserver, I faced the same issue again. This time, in addition to re-install xserver-xorg, I had to create /etc/X11/xorg.conf file (I did so by copying the backup file I already made).

share|improve this answer
show 1 more comment

I'm running Ubuntu 12.04 on a Toshiba Portege R100. I got this error after the first bootup after install. After downloading and updating the graphics driver (Trident Cyberblade), what worked for me was creating a driver-specific .conf file as described in this Arch-Linux wiki: https://wiki.archlinux.org/index.php/Trident.

share|improve this answer
show 1 more comment
  1. Press CTRL+ALT+F1 to open a terminal
  2. log in
  3. look at the end of your /var/log/Xorg.0.log
  4. if the message error is Cannot run in framebuffer mode. Please specify busIDs. then run the following commands:

    sudo apt-get install --reinstall lightdm
    sudo reboot
share|improve this answer
add comment

Wich ubuntu version are you running? Did you installed graphics drivers before the problem or is it a post clean-os-install issue? Giving some more info would be helpful for us to help you.

If you messed with the graphic drivers before the problem came up, get to the login screen, press Ctrl+Alt+F1, login, then:

  • sudo apt-get purge nvidia-*
  • sudo apt-get autoremove
  • sudo apt-get linux-source linux-headers-generic
  • sudo apt-get install nvidia-current
  • sudo nvidia-xconfig
  • sudo shutdown -r now

Of course, if you have an ATI videocard you have to change the nvidia-* and nvidia-current for your ATI drivers package.

share|improve this answer
show 1 more comment

You have too many files on your computer, and have exhausted disk space

Try moving personal files off the computer onto a USB drive.


To check whether this is the issue:

  1. Press Ctrl + Alt + F1
  2. Type df -h
  3. If you see that there is no space available on the root (/) then you need to free some space.

To free space you can:

  1. sudo apt-get autoclean
  2. Look for large directories with sudo du -sc /*/* |sort -g and delete unwanted content,
  3. Clean your home directory using a combination of

    cd ~   
    du -sc * |sort -g
    rm myLargeFile
    

When this is done, restart: shutdown -r now

share|improve this answer
2  
Thanks! This did the job for me. Initially I did not think of checking the remaining space on the SSD. –  Andre May 5 '13 at 0:31
show 7 more comments

Your Memory may be bad.

If you experience Low graphics mode intermittently like I was.

  1. Run a memory check to check for memory errors.

  2. Buy New memory(Make sure it is the right type for your computer)

  3. Run the memory test again, to make sure all is good.

The Low Graphics Mode error should now be gone.

share|improve this answer
add comment

This problem destroyed my morning. It turns out that if your root filesystem runs out of space then Ubuntu will boot into low graphics mode and it's hard to figure out why since the xorg log shows nothing wrong. To find out from the command line if you're low on space type

df -h

Sample output from my machine:

Filesystem      Size  Used Avail Use% Mounted on
/dev/sda6        18G   10G  6.6G  61% /
udev            3.9G  4.0K  3.9G   1% /dev
tmpfs           3.9G  108K  3.9G   1% /tmp
tmpfs           1.6G  1.2M  1.6G   1% /run
none            5.0M     0  5.0M   0% /run/lock
none            3.9G  1.3M  3.9G   1% /run/shm
none            100M   16K  100M   1% /run/user
/dev/sda4       317G   33G  285G  11% /media/data
/dev/sda1       197M   16M  182M   8% /boot/efi

If your / mount has a high Use% (90%+) then this could be your problem. In my case, ~/.xsession.errors had grown to fill most of my partition and caused me to fall into low-graphics mode. Found my answer for that in this Ubuntuforums thread:

rm ~/.xsession-errors
mkdir ~/.xsession-errors
share|improve this answer
add comment

Follow these commands:

sudo apt-get update
sudo apt-get -d install --reinstall gdm
sudo apt-get remove --purge gdm

(I ran this command above, but was told by the system to use # sudo apt-get autoremove instead, after the #sudo apt-get remove --purge gdm command.)

sudo apt-get install gdm

select GDM when prompted

sudo reboot

That fixed it for me :)

It took very long to start after the reboot, 10+ mins. But I got in eventually.

share|improve this answer
add comment
  • If you have a problem with the restricted (closed source) driver , then try to remove it.

Open a terminal and give this command

gksudo software-properties-gtk 

Goto Additional drivers and remove the dirver. You have to mark the Using X.Org X server -- Nouveau.

Then Reboot.

enter image description here

  • If you have not access at all to the Desktop Environment then use the Recovery Mode.

To remove the Nvidia current driver in Ubuntu 12.10

enter image description here

enter image description here

Select the Network and your root partition will mounted as Read-Write.

enter image description here

Select the Root enter image description here

And then give these commands with order

apt-get remove --purge nvidia-current 
rm /etc/X11/xorg.conf 
apt-get install ubuntu-desktop
reboot

The last command will reboot your system and hopefully you will login normally in next reboot with the Open Source nouveau driver.

  • If you have problem with the open source driver (nouveau) , in the same manner (from recovery mode) try to install the restricted (Nvidia) driver with these commands

When you reach the Root selection and after select root

To install nvidia-current driver.

 apt-get install linux-source 
 apt-get install linux-headers-$(uname -r)
 apt-get install nvidia-current 
 nvidia-xconfig 
 reboot

According to this answer : Ubuntu 12.10 Desktop does not show when I installed nvidia drivers! may need to install or reinstall the linux-headers to get the restricted Nvidia drivers work properly.

share|improve this answer
show 4 more comments

You need to install the kernel headers manually then reinstall nvidia for some reason then the nvidia drivers will work

share|improve this answer
show 2 more comments

Only for ATI graphics cards

When the message that "your system is running in low-graphics mode" appears:
Press Ctrl+Alt+F1 to see the terminal one. Then login with your credentials, and then run the following commands:

sudo apt-get install fglrx    
sudo reboot

The same can be done from the recovery mode (after enabling networking), if your Ubuntu completly refuses to enter anything but recovery mode.

share|improve this answer
add comment

The greeter is invalid

This is a bug in LightDM and a bug report has already been filed.

The reason why you end up with this failsafe X is because the pantheon-greeter you installed along with the elementary desktop is now not available and LightDM is not able to identify an alternative greeter.

As a workaround, you can edit the LightDM conf file and correct the error.

Run the following command in a terminal:

sudo nano /etc/lightdm/lightdm.conf

and change the line

greeter-session=pantheon-greeter

to

greeter-session=unity-greeter

and save it.

After changing the file, reboot and you will now be greeted with Unity greeter.

share|improve this answer
1  
This doesn't help in my case. I already have the unity-greeter in /etc/lightdm/lightdm.conf –  Sauli Oct 23 '13 at 11:23
show 3 more comments

I solved this problem by reinstalling ubuntu-desktop.

When the message that "your system is running in low-graphics mode" appears, press Ctrl+Alt+F1, then login with your credentials.

And then, run the following commands:

  • sudo apt-get install --reinstall ubuntu-desktop
  • sudo reboot
share|improve this answer
1  
when i give this command!i got memory is full no more space available! –  Thiyagu Apr 4 '13 at 14:33
2  
This may help when the problem is to do with the desktop, but usually for me this type of problem comes from a combination of the graphics drivers and a kernel upgrade. In this case the other answers here are more appropriate, with particular reference to @Luis. –  Bobble Jun 12 '13 at 6:06
add comment

I had the same problem with an Acer Aspire 3810tg. I solved it by doing the following:

  • Do a normal boot
  • Press Ctrl-Alt-F1 on the "Your system is running in low-graphics mode" screen
  • Download the correct driver from http://support.amd.com/us/gpudownload/Pages/index.aspx, in my case (ATI Mobility Radeon HD 4330): wget http://www2.ati.com/drivers/linux/amd-driver-installer-12-4-x86.x86_64.run which should also cover your case (Mobility Radeon HD 4xxx Series)
  • chmod 755 amd-driver-installer-12-4-x86.x86_64.run to make the file executable
  • sudo ./amd-driver-installer-12-4-x86.x86_64.run and follow the standard steps
  • You might need to run: sudo aticonfig --initial, but that was not necessary for me.

In my case the driver installation finished with an error, but it still worked. I hope this helps.

share|improve this answer
add comment

Well, I had the same problem and solved it.

  1. Start ubuntu with recovery mode from grub then choose filesystem check followed by enable networking.

  2. Choose root option to get to terminal. Now uninstall the old drivers

    sh /usr/share/ati/fglrx-uninstall

  3. Then reinstall the drivers following the methods for precise from this website https://help.ubuntu.com/community/BinaryDriverHowto/ATI.

  4. After that everything works out just fine, I suggest you do

    apt-get update && apt-get upgrade && apt-get autoremove

    -everytime you complete a step. Good luck.

share|improve this answer
add comment

I have recently received a similar issue with myPangolin Performance laptop. The folks at System 76 told me to do the following:

Click Okay and then select the option to get a terminal. (alternatively you can press ctr+alt+f1 to bring up another tty)

sudo chown lightdm:lightdm -R /var/lib/lightdm
sudo chown avahi-autoipd:avahi-autoipd -R /var/lib/avahi-autoipd
sudo chown colord:colord -R /var/lib/colord

reboot

These commands did the trick for me.

share|improve this answer
add comment

I had the issue when I upgraded from 11.10 on my Acer Aspire One AO-722. I also had the propriety ATi/AMD driver installed from 11.10, which carried over to the 12.04 installation. I followed this guide to remove the proprietary drivers and use the Open Source drivers. http://wiki.cchtml.com/index.php/Ubuntu_Oneiric_Installation_Guide#Removing_Catalyst.2Ffglrx Everything seems to be working now.

share|improve this answer
1  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  fossfreedom May 7 '12 at 8:58
add comment

When this happens there is often an error message indicating why it failed to start X.

Look in your /var/log/Xorg.0.log.old or /var/log/Xorg.0.log. The error (if there is one) will be at the tail end of the file. Another good place to look is the log files in /var/log/gdm/* (or /var/log/lightdm/* in oneiric).

Did you happen to manually install fglrx prior to noticing the problem? If it was not uninstalled properly it can cause weird random issues. Directions for purging fglrx are available at here.

Is your video card an AGP model? If so, a common issue with ati agp cards is having an incorrect AGPMode. Sometimes you can adjust this setting in your BIOS (which perhaps windows screwed with?) There is also a setting in /etc/X11/xorg.conf for adjusting it in X.

share|improve this answer
add comment

I had a similar problem.

When I was booting my PC, i was getting the following message: “Ubuntu is running in low-graphics mode”

When I used startx on the command prompt however, everything was fine and i could start the xserver.

Now I found out that for some strange reason GDM has been uninstalled (it took me hours to realize that), i did fix the problem by reinstalling gdm with:

apt-get install gdm

now everything's running. Hope this helps you.

share|improve this answer
add comment

protected by Community Oct 19 '12 at 11:33

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.