Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.


This is an attempt to create a canonical question that covers all instances of "low-graphics mode" error that occurs to a user, including but not limited to installation of wrong drivers, incorrect or invalid lightdm greeters, low disk space, incorrect installation of graphics card like ATI and Nvidia, incorrect configuration of xorg.conf file while setting up multiple monitors among others.

If you are experiencing the "low-graphics mode" error when trying to login but none of the following answers work for you, please do ask a new question and then update the answers of this canonical question as and when your new question gets answered.

When I try to boot into my computer, I am getting this error:

The system is running in low-graphics mode

Your screen, graphics cards, and input device settings could not be detected correctly. You will need to configure these yourself.

fail-safe X mode

How do I fix the failsafe X mode and login into my computer?

Answer index:

share|improve this question

39 Answers 39

I just had to disable Internal Graphics Board on BIOS display.

Using ga-z87n/ga-h87n (GIGABYTE) motherboard.

share|improve this answer

I had the “The system is running in low-graphics mode” error after trying to upgrade my Acer Aspire 4810T with Intel GM45 Express Chipset graphics from a 64bit 13.04 to a 64bit 13.10.

I had less than 2 gigabytes of free disk space when I started the upgrade. I faced first anomalies already before the reboot. The upgrade window showing the progress showed that everything has been downloaded and installed but it never closed. Couldn't close it even manually.

Then, after reboot, I got the “The system is running in low-graphics mode” error window.

I tried to solve the problem as proposed above by Luis Alvarado, user41938, community wiki, Azul Mascara and David M. Sousa.

My guess is that my problem was related to tiny disk space as hinted by Azul Mascara. But just freeing disk space and even allocating more by repartitioning didn't help.

After struggling more than enough with the problem I decided to download the 13.10 64bit and make a bootable USB stick with it. I booted the laptop with the USB stick and selected the installation on top of the old 13.10 (non-functioning) system that the installer recognized. This fixed my problem.

share|improve this answer

I had the same problem but this method works for me.

When you get The system is running low-graphics mode error,press ctrl+alt+F1 ,it will take you to the console.
Then it will asks for username and passwordto login,give that.Once you logged in to the console run the below command,

sudo rm /etc/X11/xorg.conf
sudo service lightdm restart

It will get you back to the GUI login.Why this problem occurs means,after you installed graphics drivers,it creates xorg.conf file in /etc/X11 folder.Which prevents the system from GUI login.

share|improve this answer

First, type the following commands:

$ lspci | grep -i VGA
$ lspci | grep -i amd

For me (HP pavilion 15n003tx, Saucy), the outputs were:

test@HP-Pavilion-15:/etc/X11$ lspci | grep -i VGA
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
test@HP-Pavilion-15:/etc/X11$ lspci | grep -i amd
0a:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M]

Since the AMD device doesn't come as output in the first command, even if you install amd drivers, you'll probably end up with the following error in /var/log/Xorg.0.log:

[    12.873] (II) fglrx(0): Invalid ATI BIOS from int10, the adapter is not VGA-enabled

Hence, I followed the steps:

test@HP-Pavilion-15:/etc/X11$ sudo apt-get purge fglrx*
test@HP-Pavilion-15:/etc/X11$ cp /etc/Xorg/xorg.conf.failsafe /etc/xorg.conf

The contents of xorg.conf.failsafe are:

Section "Device"
    Identifier  "Configured Video Device"
    Driver      "fbdev"

Section "Monitor"
    Identifier  "Configured Monitor"

Section "Screen"
    Identifier  "Default Screen"
    Monitor     "Configured Monitor"
    Device      "Configured Video Device"
share|improve this answer

I fixed this problem by removing /var/lib/lightdm/.Xauthority manually.

You can also try deleting the file ~/.Xauthority and rebooting.

share|improve this answer

I have the same problem (The system is running in low-graphics mode) when I reboot the system connected to an Oculus Rift (1080x1920 monitor). If I reboot the machine and connect a monitor of (1920x1080 resolution) it works ok.

The machine has Ubuntu 14.04 and Nvidia 970, driver 346 and kernel 3.15. With the default lightdm configuration (autologin activated).

The problem started suddenly, without making major changes in Ubuntu configuration.

I had the same issue in another machine with nvidia 970, same version of Ubuntu / different kernel. On this machine the problem happened when changing from autologin to login with user/pw in lightm and it was solved rebooting the machine with a 1920x1080 monitor connected and enabling autologin again.

share|improve this answer

For me this problem occurred after upgrading from "Ubuntu 12.04 LTS" plus TDE to "Ubuntu 14.04 LTS" plus TDE. TDE is the trinity desktop environment ( The cause of the error was that

  1. /etc/X11/default-display-manager pointed to lightdm although during the upgrade I told it to use tdm-trinity as default.
  2. lightdm was broken (and I don't care why).

The fix was to run dpkg-reconfigure tdm-trinity and to choose tdm-trinity as my default. A few days later the problem came back and again /etc/X11/default-display-manager pointed to lightdm, don't know why.

share|improve this answer

This one worked for me using ubuntu 13.10, my ubuntu stopped working after installing opencv.

sudo apt-get purge nvidia-304 nvidia-current nvidia-libopencl1-304 nvidia-settings 

Just purge all the nvidia-* and restart

I am not a geek just a layman don't know the reason why it works.

share|improve this answer

Go to System, Administration and click on Hardware drivers (in Maverick it is called Additional Drivers). It will search for and allow you to install the proper graphics driver which should allow you to run in higher res.

In Linux there are two ways to do most things, by the GUI or by the terminal. This is easier for most people used to a graphical user interface. The second GUI way to do it would be to go to Software Center or Synaptic and install the packages in the previous post. Search for them in the search bar. I don't think that Ubuntu has used xorg.conf for awhile, so it would not help to look for it.

share|improve this answer

protected by Community Oct 19 '12 at 11:33

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.