Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

how can I allow standard users to connect to wireless network without administrator password? It's simple question. I need any positive answer.

share|improve this question
1  
Do you need standard users to be able to configure new wireless networks or just access existing ones? If it's the latter have you tried checking Available to all users at the bottom of the wireless network configuration window in the Network-Manager GUI? –  adempewolff May 24 '12 at 8:51

2 Answers 2

To make a wireless network available to all users we need to make shure that all users have the privilege to "Connect to wireless and ethernet networks". You can set this from Users and Groups from the package gnome-system-tools Install gnome-system-tools

(see also this question).

To make a wireless network available to all users we also need to tick the box "Available to all users" on the bottom left side of Edit connections -> Wireless -> Edit:

enter image description here

share|improve this answer
    
Is there any way to allow them connecting to wireless network that i hadn't created in list of network connections.For example if my standard user finds himself in area where he can connect to network that is new for my laptop. –  Marko May 28 '12 at 8:51
    
Marko - yes there is, since this is so old i wont explain.. haha.. msg me if you want. –  Banned_User May 17 at 23:27

To expound on Takkat's answer, to give a standard user permission to connect to any wireless network (even as yet unknown ones):

  1. Install gnome-system-tools, e.g. sudo apt-get install gnome-system-tools
  2. Launch the program "Users and Groups".
  3. Select the user, click "Advanced Settings" then the "User Privleges" tab.
  4. Check "Connect to wireless and ethernet networks", then click save.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.