Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

boot repair output

installed 12.04 alongside XP, but no grub selection at boot, defaults to Ubuntu only. I've tried reinstalling several times. I can boot to XP by using boot repair and then can boot back to Ubuntu by using repair off of USB, but I've still not been able to create the boot option for both? What settings in boot repair should I use to achieve this? Or is there another way? Speak slowly as I am n00b.

share|improve this question
    
Have tried modifying GRUB bootloader? –  Mitch May 24 '12 at 7:55
    
No, but I would need instruction on how and what to change. –  ghalalb May 24 '12 at 7:56
    
I'm facing same issue, I've tried first and second answers of this post failed. –  Mahesh.D Feb 16 '13 at 12:52
add comment

4 Answers

I would give Boot Repair a go which you can find details about here

Boot-Repair

This as they detail is

Boot-Repair is a simple tool to repair frequent boot issues you may encounter in Ubuntu like when you can't boot Ubuntu after installing Windows or another Linux distribution, or when you can't boot Windows after installing Ubuntu, or when GRUB is not displayed anymore, some upgrade breaks GRUB, etc.

As it looks as if your Ubuntu is at least working I would install it in Ubuntu using the following commands in a terminal (which may look tricksy but it is not really. Open a terminal up (ctrl-alt-t) and type in the following:

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update

then

sudo apt-get install -y boot-repair && boot-repair

The link above has a guide on how to use but basically it is as follows :

Using Boot-Repair

Recommended repair

launch Boot-Repair from either :
    the dash (Unity)

    System->Administration->Boot-Repair menu (Gnome)
    by typing 'boot-repair' in a terminal 
Then try "Recommended repair" button. When repair is finished, note the URL that appeared on a paper, then reboot and check if you recovered access to your OSs. 

Hope that helps

Let us know how you get on.

share|improve this answer
    
thanks andybleaden. I've found the problem, and its so stupid I hope it makes you laugh. I can't "see" the GRUB screen because its out of range. So i need to figure out how to fix this. I stumbled on this while it was booting. Thought i'd arrow down to see what input it gave, and discovered I could boot into XP (I remembered that Windows would be last on the list). So now I need to set up GRUB screen res at boot to something that is recognised. –  ghalalb May 25 '12 at 10:59
    
well done!Glad you found a solution –  andybleaden May 25 '12 at 16:37
add comment

Simple answer to your question. While your computer boots, hold the shift key and you should see the grub menu. :)

You may want to configure grub to stop this behavior, I recommend trying grub customizer. Here's a link with all the info you need on that: http://ubuntuforums.org/showthread.php?t=1664134

share|improve this answer
add comment

I would recommend that you use Super Grub Disk. You can Get it Here

I hope that will work for you.

share|improve this answer
    
Thanks Mitch, gave that a try but it's just coming up with grub rescue, no menu. –  ghalalb May 24 '12 at 9:22
add comment

As you have the "out of range" error, just use the "out of range" option of Boot-Repair (Boot-Repair -> Advanced options -> GRUB options -> out of range).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.