Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to upgrade from 10.10 to 11.04 but it crashed. It couldn't mount disk drives so I did a new installation without erasing the previous drives. Now I can't access access-your-private-data.

share|improve this question
    
I'm guessing by your tag that your old home folder was encrypted? Just a tip, I know this is stressful, but if you want someone to help you with this you are going to need to be a lot more specific with what happened and what errors you are encountering. –  adempewolff May 24 '12 at 5:39
    
Initially i was working on ubuntu 10.10, then i tried to upgrade to 11.04 throught update manager everything was until it installed all the packages. It stopped suddenly and i only had the option to use the power button and restart. And at the loader it said that the "disk drive for / is not ready or not present" Press S to skip memory test or M for manual recovery, Pressing "S" then gives the message but instead of disk drives it is tmp,manually, have to try the method described here goshawknest.wordpress.com/2010/04/16/… –  prr May 24 '12 at 6:24
add comment

1 Answer 1

I have this same problem, and discovered ecryptfs-recover-private from Dustin Kirkland's blog. This utility interactively asks for your login password, which I have, and then mounted my old home directory in /tmp/ecrypt.hAsHeD and I am now able to copy out everything I need.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.