Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have used 10.04 with the b43-fwcutter driver to drive my BCM4318 Broadcom card (a Linksys WPC54G v3) on my old Dell Inspiron 8100 for two years+ with no troubles. I just upgraded to 12.04 and although everything worked fine after install, before I added the b43-fwcutter driver, once I installed the driver, the system refuses to boot. Even before I install the Linksys card!! It just hangs on boot with graphical garbage on the screen. I tried several attempts to recover the system using the live CD, and finally reinstalled completely. I have been thru the cycle, install fresh system, verify everything works, then install b43-fwcutter and it is hung, several times. Consistent hard fail.

The system runs fine on hardwire Ethernet, and wireless was fine on 10.04. But I cannot get there with 12.04. So after several attempts, I am now ready to admit defeat and ask for help.

I have read every thread that search turned up, and either the advice is to do what I did, i.e. install fwcutter, or does not apply (Different Broadcom, STA, legacy, whatever)

So what do I need to do to fix it? Or is the B43-fwcutter driver broken for 12.04?

Thoughts? Tips? Log files needed??

share|improve this question
    
What graphical garbage? –  izx May 24 '12 at 3:44
    
Can you boot in recovery mode? Can you see any errors if you use Ctrl-Alt-F1? It may be time to report a bug for the b43-fwcutter package on Launchpad (if possible). –  John S Gruber May 24 '12 at 21:13
    
The only way I can boot once the fwcutter package is installed is to boot the live CD. The system is completely hosed and unbootable. I tried the "repair" option but that didn't do anything useful. The only way I could do anything was reinstall. Presumably, I could retrieve a log file or other troubleshooting data from the dead system using the live CD, but I don't know what to look for. The graphical garbage is just some vertical lines and gibberish text. Meaningless to me. It should be possible I think to uninstall the fwcutter from the live CD but I don't know how. –  Nathan May 25 '12 at 4:29
    
Before actually reporting a bug I would like to better quantify what is failing, and eliminate some other ways things might be going off the rails, such as a simple corrupt file, or it not getting installed correctly, or wrong version, etc. I looked at the notes on the b43-fwcutter package itself, and although I am kinda lost in the weeds it does appear as if there were a few changes between 10.04 and 12.04. It did work rather well in 10.04, hard to see what went wrong that could lead to such a catastropic fail. Any guidance you can offer on troubleshooting is welcome... –  Nathan May 25 '12 at 4:36
    
Ok, I've learned something. I've never had to play with Grub before and was unfamiliar with it. But after poking at things a while and learning a bit about Grub, I discovered that the "Graphical Garbage" I was seeing was actually Grub's screen. Somehow, on this machine the default installation video mode was broken. Maybe that is a bug in it's own right. So after studying the Grub docs a bit, I changed the video mode, and now I have a useful Grub menu. My next step is to reinstall the b43-fwcutter and then see if I can recover using Grub. And thereby grab any troubleshooting info. –  Nathan May 25 '12 at 15:11

1 Answer 1

SOLVED! This was a multifaceted problem. First my own unfamiliarity with Grub did not let me recognize that Grub was trying to tell me something but it's incorrect video setting was just showing garbage. Reconfiguring Grub solved that. Second, something bogus was installed that was conflicting with the card, causing it to be activated even with no b43 driver installed, and it was then hanging the system. I removed several things I could not identify and then suddenly I could get it to run, with complaints that the firmware was not installed. I am not sure exactly what I removed that got around the problem. Then I installed the firmware per the standard instructions here and is all started working. Note I had installed the firmware before but it didn't work, since the bogus something or other was hanging things up. It is working now, and I am posting this answer over the Wifi link. Thanks for all the help...

share|improve this answer
    
add link: help.ubuntu.com/community/WifiDocs/Driver/bcm43xx –  david6 May 26 '12 at 6:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.