Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Lucid install won't boot properly anymore. I can boot the computer with a USB-stick-ubuntu and edit settings. I have edited grub.cfg to not boot "quiet splash" and changed the default runlevel to 1.

When continuing to boot from the recovery menu, I get this line:

init: rsyslog main process ended, respawning.

I did a aptitude reinstall rsyslog, which changed nothing. Does someone have an idea where to continue searching for the cause?

Thanks in advance,

share|improve this question
    
The problem probably has to do with your rsyslog configuration (either there's something wrong there or there's something wrong in the places where you're sending logs). Post the contents of your configuration files (/etc/rsyslog.conf, /etc/default/rsyslog, /etc/init/rsyslog.conf, any file in the rsyslog package that you've changed). –  Gilles Nov 20 '10 at 13:41

1 Answer 1

The primary configuration file for changing menu display settings is /etc/default/grub. Configuration changes are normally made to /etc/default/grub and to the custom files located in /etc/grub.d.

The /boot/grub/grub.cfg file should not be edited by the user; changes to this file are made by configuration scripts.

grub.cfg is overwritten anytime there is an update, a kernel is added/removed, or the user runs update-grub. After editing /etc/default/grub, you need to run sudo update-grub for your changes to take effect on the next boot.

The user can use a custom file, /etc/grub.d/40_custom, in which the user can place his own entries. This file will not be overwritten.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.