Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Micromax 3G modem, and I inserted it in the USB port, but it is not being detected by Ubuntu 12.04, that I'm using from a Live USB. I tried creating a mobile Internet connection, however, eventhough I created it, there is no option to connect.

I had previously used 11.10 Ubuntu, and it had automatically detected the datastick modem and asked me to create a connection.

On typing lsusb in the terminal it gives the following:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 03f0:5307 Hewlett-Packard 
Bus 001 Device 008: ID 1c9e:9605 OMEGA TECHNOLOGY 
Bus 001 Device 006: ID 5986:0364 Acer, Inc 

tried to insert the modem before boot, with negative results

share|improve this question

2 Answers 2

up vote 5 down vote accepted

Since we have the same vendor & product ID, create your config same as what i have:

gksudo gedit /etc/usb_modeswitch.d/1c9e:9605

Paste this code on the editor

DefaultVendor = 0x1c9e
DefaultProduct = 0x9605
TargetVendor = 0x1c9e
TargetProduct = 0x9605

Save and exit, then log in as root to your terminal:


Type & confirm your root password, and do:

modprobe usbserial vendor=0x1c9e product=0x9605

usb_modeswitch -c /etc/usb_modeswitch.d/1c9e\:9605

If you didn't receive any error messages, you'll then see a new Mobile Broadband Connection on your Network Manager (top right wifi icon)

you need to run this code every session but you can just add the code below to your /etc/rc.local (insert before the 'exit 0') so it will be part of your startup programs:

 sleep 10
 modprobe usbserial vendor=0x1c9e product=0x9605
 usb_modeswitch -c /etc/usb_modeswitch.d/1c9e\:9605
 sleep 20
 nmcli nm wwan on
 sleep 10
 nmcli con up id "your connection name here"

Hope this helps ..

share|improve this answer

Followed the steps in the below mentioned link to configure the micromax 3G modem under the Ubuntu 12.04/12.10/13.04


share|improve this answer
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eric Carvalho Jul 3 '13 at 10:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.