Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had installed Ubuntu 12.04 on a separate partition, in ext4 format in my comp, which initially had only Windows 7. I had done the installation from a Live USB, which gave me the option Install on boot, in a GRUB menu.

I had chosen the option of "Installing Ubuntu alongside Windows". I had chosen the particular partition during the install, and in mount part, I had given /.

And I chose my only hard disk drive as the location to install the bootloader. The whole install process was over, and I was asked to restart, and while doing to it asked me to remove my installation media, which in my case was a Live USB.

I acted accordingly and removed it. While booting however, it booted directly in Windows, and no menu or option came for me to choose from both.

share|improve this question
    
First thing to try is to hold down the Shift key while booting. It's a long shot, but if Grub (the bootloader) is installed, just not appearing that should force it out of hiding.. –  agc93 May 24 '12 at 2:02
    
Put the USB back in and boot and see what happens, as well. –  wojox May 24 '12 at 2:16
    
agc93 , I have tried holding down the shift key with negative results. @wojox , it gives me a menu to install ubuntu, or to try without instlling, or to check disc for error. i tried the third one, and it said 0 errors –  arjith May 24 '12 at 2:56
    
Do one thing , If you still have your Live Usb, please run Ubuntu .Start installation (But don't install), then at the Gparted Partition Menu ,take the screenshot and post it here, if you cant post screenshot ,post it somewhere and provide the link here. –  atenz May 24 '12 at 7:43
    
@tijybba , the live usb booted ubuntu does not detect my Micromax 3G stick, which i've posted in another question on <askubuntu.com> I tried taking screenshots in ubuntu, pasting it in a common drive and then uploading it from windows, however, it says the image format is not supported, eventhough it is simple png format. kinda freaking out cos i need this installed within 2 days cos my net pack gets over in 2. What queries you have regarding my partitions kindly ask i'll explain. –  arjith May 24 '12 at 9:39
show 6 more comments

3 Answers 3

Maybe there is a Windows recovery environment (just maybe) and you chose that place as the place to install GBUB.

Whatever reason, follow these steps to restore GRUB.

Keep in mind that it doesn't overwrite the MBR, instead it adds a GRUB entry to the windows Bootloader.

Source

  1. Download Easybcd here. It's a tool that can edit the windows bootloader and it is a very popular program along Windows-Ubuntu users.
  2. Open EasyBCD.
  3. Go to "Add new entry"> Linux/BSD and then select GRUB2 from the dropdown menu. Name the entry whatever you want, like "I love linux" or "Ubuntu GRUB".

enter image description here

That's it! You should see a GRUB entry in the Windows boot menu when you reboot. Select it and choose "Ubuntu generic . . . . . .pae" from the GRUB menu(if the installation failed then you might not see it).

Good Luck!

share|improve this answer
    
I'll try that and tell you whether i was successful, however i have one query, will doing this affect in anyway my windows OS? or will it be difficult to uninstall in future? (I'm gonna do this anyway, however just wanted to know) –  arjith May 24 '12 at 2:57
    
I didnt choose any place to install GRUB, i just used '/' in mount and chose dev/sda which is my only harddisc to install the bootloader –  arjith May 24 '12 at 3:00
    
I tried it, and the mentioned option came in windows boot menu, however,it goes to a dos like scree, called GRUB-(SOME VERSION)-DOS, asking me to type some path or command, similar to bash, which i dont know, i also dont know where the bootloader file is. So wat should i do now? –  arjith May 24 '12 at 3:35
1  
listen, i'm getting a screen with nothing but grub> –  arjith May 24 '12 at 7:53
    
there is a windows recovery environment, however i had given the location of the harddisc and not the partition of windows recovery as the location to install bootloader –  arjith May 24 '12 at 8:45
show 9 more comments

It worked for me. I had installed Ubuntu 12.04 alongside Windows 7. But in boot menu there was just Windows 7. By using easyBCD I have it solved and now I have Ubuntu in boot menu. Notice that I wrote Ubuntu 12.04 instead of Ubuntu 10.04 which is seen above.

share|improve this answer
add comment

My bad. I had downloaded the 64 bit version, since I had an x64 Windows OS. But then I tried the i386 32-bit one, and it is working perfectly. I thank you all for your help.

share|improve this answer
    
You can accept your own answer later. –  Emerson Hsieh Jun 27 '12 at 3:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.