Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running the new Ubuntu 12.04 64-bit release on my MSI CX420 laptop. It has 2 GPUs, an ATI and an Intel integrated one.

So my problem is that, whenever I start my laptop for the first time, vgaswitcheroo does not seem to be loaded as the path

/sys/kernel/debug/vgaswitcheroo/switch

does not exist yet my ATI card seems to be powered still and heats up my laptop to a painful to the hands degree. However, when I restart the computer, vgaswitcheroo finally appears. Although the workaround may be easy, but it gets annoying really if I have to start the computer every time.

Now, I'm thinking of submitting a bug to launchpad, but not sure if this really is a bug (or what package it is, if it is a bug)

I do have a custom startup script though in /etc/rc.local, it simply turns off the ATI card (when vgaswitcheroo exists). It looks like this, and it might pose an impact to my problem:

until [ -e /sys/kernel/debug/vgaswitcheroo/switch ]; do
   : # do absolutely nothing
done

chmod a+rx /sys/kernel/debug
chmod a+w /sys/kernel/debug/vgaswitcheroo/switch

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

any help / advice would be great! Thanks

share|improve this question
add comment

2 Answers

I am not sure whether this is your problem but you definitely need to mount the debugfs:

sudo mount -t debugfs none /sys/kernel/debug/

After that the needed files should hopefully appear.

To make the debugfs visible permanently you have to add an entry to your /etc/fstab that always mounts the debugfs at boot time. Sorry, but I am a bit lazy to look up the exact line that you would need to put in your /etc/fstab but I hope this helps anyway.

share|improve this answer
    
Looks like the debugfs is already mounted because the command is reporting mount: none already mounted or /sys/kernel/debug busy mount: according to mtab, none is already mounted on /sys/kernel/debug It seems like the GPU itself is not being detected by the kernel because running lspci | grep VGA reports only 1 GPU But I really appreciate the response! Thanks! –  aeroheart-c6 May 29 '12 at 3:35
add comment

You may try to check kernel parameters while it loads (when you see a GRUB screen on boot) - if there is a nomodeset parameter, you must delete it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.