Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install the OMAP4 extras for ubuntu on my pandaboard. For some reason, a few packages can't seem to be agree with eachother.

This what I did so far:

  • installed on Ubuntu 11.10 on sd card
  • Powered on Pandaboard and let it finish it's initial install
  • Did an "apt-get update" and "apt-get upgrade", to install updates

So far, everything went fine, and I was quite happy with my Pandaboard, but then I made the mistake of typing this:

apt-get install ubuntu-imap4-extras

At first, everything seemed ok, and it started downloading and installing. But then after a while it just crashed. I tried it again but then it gave me this:

Reading package lists... Done
Building dependency tree
Reading state information... Done
ubuntu-omap4-extras is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
gstreamer0.10-openmax : Depends: gstreamer0.10-plugins-bad but it is not going to be installed
gstreamer0.10-plugin-ducati : Depends: gstreamer0.10-plugins-bad but it is not going to be installed
ubuntu-omap4-extras-multimedia : Depends: gstreamer0.10-plugins-bad (>= 0.10.22-2ubuntu4+ti1.5) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

So I tried to the suggestion: apt-get -f install:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
gstreamer0.10-plugins-bad
The following NEW packages will be installed:
gstreamer0.10-plugins-bad
0 upgraded, 1 newly installed, 0 to remove and 4 not upgraded.
88 not fully installed or removed.
Need to get 0 B/1,794 kB of archives.
After this operation, 4,571 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 143575 files and directories currently installed.)
Unpacking gstreamer0.10-plugins-bad (from .../gstreamer0.10-plugins bad_0.10.22-2ubuntu4+ti1.5.4.8+1_armel.deb) ...
dpkg: error processing /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-2ubuntu4+ti1.5.4.8+1_armel.deb (--unpack):
trying to overwrite '/usr/lib/libgstbasecamerabinsrc-0.10.so.0.0.0', which is also in package gstreamer0.10-plugins-good 0.10.30-1ubuntu7.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-2ubuntu4+ti1.5.4.8+1_armel.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Seems like two packages (plugins-good and plugins-bad) are fighting over the same library.

Any idea on how to fix this??

share|improve this question

2 Answers 2

Try this to clean and update your system

sudo apt-get autoremove
sudo apt-get clean
sudo apt-get autoclean
sudo apt-get update
sudo apt-get upgrade
share|improve this answer

My steps to solve this problem:

dpkg -r --force all gstreamer0.10-plugins-good
apt-get -f install
apt-get install ubuntu-omap4-extras

Force to remove the good package first!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.