Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu 12.04 desktop edition on my PC using VMWare workstation 7. I assigned 1GB RAM and 20 GB Hard disk to Ubuntu.

While starting Ubuntu virtual machine, It is not starting up with GUI mode. In is prompting me my Login ID in textual mode always. After waiting for long time as well the GUI mode is not appearing.

I tried running sudo apt-get install updates sudo apt-get install xinit sudo apt-get install ubuntu-desktop

Honestly, i don't know the meaning of all these.I am very new to ubuntu.Please help me here what to do?

Below is my Laptop configuration OS: Genuine Windows 7 Home Basic(64 bit) RAM: 3 GB Processor: Intel core i3

Regards Salil

share|improve this question
Please post the logs from /var/log/syslog – Andrejs Cainikovs May 23 '12 at 18:10
<code>sudo /etc/init.d/gdm start</code> worked for me – Sajjad Ashraf Mar 24 '13 at 19:08

You may try sudo lightdm, startx, sudo startx, or sudo gdm in that order of preference(Use the first that works). You may then try to set it up as the last entry in the system-wide crontab(See

share|improve this answer

Today I installed the 12.04 version and found the same problem as no GUI was seen. But after running the command "startx"I got the solution.

share|improve this answer

Caution !

After installing Ubuntu under Vmware xx be sure that the vmware tools are installed as well, you should receive a message from Ubuntu to explain that but in some case not, so be patient.

Otherwise, startx work as well.

share|improve this answer

Ok, new to posting: using VMWare 4.1 with Ubuntu 12.04 as VM or Guest. Graphics not working as expected after finding that this was a common problem. Was able to login through defaulted shell. Ran the following command sudo lighdm System started right up. Long story short, open terminal and edit your system wide crontab.

sudo nano /etc/crontab

After last hash-tag enter and save the following line.

@reboot root lightdm

After several reboots, system seems to have no problems. And hopefully never will. Can't say for sure that this is the best solution...

share|improve this answer

protected by Community Oct 23 '13 at 11:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.