Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having issues with my video card drivers: GeForce 9600 GT/PCI/SSE2 When installing Nouveau - not getting 3d support and the 2d is really buggy, fuzzy fonts and lots of other stuff. Really ugly. When installing Nvidia drivers, getting 3d support, but not 2 monitors. When using nvidia settings, and setting up 2 monitors, X crashes on weird occasions, like opening skype, or VirtualBox... I'm guessing the popup windows killing it... Really weird stuff...

have no idea what else can I do to make this work right.


EDIT: ok, so I've narrowed down the issue. when using just NVIDIA drivers, and empty xorg.conf everything work ok, except dual screens - I get only one screen, and I'm using Nvidia Settings to get it working as dual screens, but when I save the configuration to xorg.conf, after restarting X, I'm back to chrashing on skype etc.

the xorg.conf saved by Nvidia Settings:

user@ubuntu:~$ cat /etc/X11/xorg.conf
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 280.13  (buildd@yellow)  Fri Aug  5 12:31:28 UTC 2011

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
    FontPath        "unix/:7100"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9600 GT"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT-0: nvidia-auto-select +1280+0, CRT-1: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
share|improve this question

2 Answers 2

up vote 2 down vote accepted

I've solved this by commenting out:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
#    InputDevice    "Keyboard0" "CoreKeyboard"
#    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

#Section "Files"
#    FontPath        "unix/:7100"
#EndSection

#Section "InputDevice"
#    # generated from default
#    Identifier     "Mouse0"
#    Driver         "mouse"
#    Option         "Protocol" "auto"
#    Option         "Device" "/dev/psaux"
#    Option         "Emulate3Buttons" "no"
#    Option         "ZAxisMapping" "4 5"
#EndSection

#Section "InputDevice"
#    # generated from default
#    Identifier     "Keyboard0"
#    Driver         "kbd"
#EndSection
share|improve this answer
    
Damn, that solution turned my PC into a brick. Just restored xorg.conf :) –  uncle Lem Nov 29 '13 at 20:08

Commenting out the lines below in the xorg.conf files, which were generated by the nvidia-settings tool, fixed the xorg crash issue for me. I haven't researched what those lines are supposed to do though.

Section "Files"
    FontPath        "unix/:7100"
EndSection
share|improve this answer
    
Well, it didn't work for me... but then I've commented out also all Mouse/Keyboard related directives, and so far so good! –  alechko Jun 17 '12 at 10:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.