Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday, I rebooted the server and it booted up to grub. Screen says 'Minimal BASH-like .... etc'. I've tried booting to the Server rescue mode from the install disk and tried reinstalling grub. I've tried the Boot Rescue Disk, still doesn't boot. I can get in and see all my files via the server rescue mode, but grub will not boot anything. No menu comes up, just the grub cli. I only have my boot drive plugged in. I've disconnected the other drives for now. I don't know what's going on or how to fix it!

http://paste.ubuntu.com/1002267/

12.04, no hardware/software raid

share|improve this question
1  
So the problem wasn't with grub, somehow my /boot directory got fubar'd and there wasn't actually any kernel in it. Following the directions (loosely) here: askubuntu.com/questions/117027/… I was able to reinstall my kernel and boot into my system! –  Kristyn McNally May 23 '12 at 16:01
    
I see you resolved your problem in about two hours. That's great. You don't mention which of the answers in that question you used. I wonder if it would help others if you could: edit your question so it indicates how you saw that the /boot file was messed up, and add an answer that says how you recovered (it's actually encouraged on askubuntu to answer your own question if you've solved the problem and it could help others in the same situation). –  John S Gruber May 23 '12 at 18:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.