Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Okay, so having some problems with this. As a newbie, this is black magic to me.

I used the alternate 32-bit installation (via a live USB), and selected “Install” as the option. As the steps progressed, I chose the option of guided installation with encrypted LVM, and “no” for the option to encrypt the home folder (why bother if the whole drive is encrypted, right?). Later, I selected “Ubuntu desktop” as the type of installation. It asks me to install Grub (its the only operating system on the machine) to the master boot loader (or some such) and I have said “yes” – I tried that on one attempt, tried to specify /dev/sda on a second attempt (I hope I have spelt that right), but no luck.

All seemed to go just fine during the installation. However, on rebooting after the installation, the first problem is the screen. After the Dell startup screen it switches into its boot processes (I guess), but the screen goes dead – not black, it actually powers off. However, on one attempt I plugged in a second monitor, and hey presto, up it came on both monitor and laptop, and remained on the laptop when I unplugged the monitor. This is not a sustainable solution, but I can deal with it for now.

That dead screen actually hides the prompt for entering the passphrase for the encryption. So I do that, and we move on. If I haven't used the second monitor trick, the screen stays dead, although it does briefly flick into blank and black for a moment.

Next challenge – its asking me for a login to the computer. I enter my user name and password, and we're through... to a command line prompt that welcomes me to Ubuntu 12.04 LTS (GNU/Linux 3.2.0-24-generic-pae i686).

That “686” surprises me, as I thought that first “6” indicates a 64-bit setup? I was sure I followed the link to 32 bit, but.... So, I start again with a fresh installation of the 32-bit alternate ISO on the usb, and...

straight back to here, this prompt that does nothing.

I can't figure out what to do from here. Help. (FYI, what I did looked very like this video http://youtu.be/V4Bje0sLblo)

Its a Dell Latitude D420.


an update (next day)

Well, thank you very much for the help.

For the record, I had tried 'startx', and had no luck - it prompted me to install... grub, I think, and it didn't work then, either.

This time, I jumped straight to an installation of Lubuntu. I followed the guides, but this time selected 'manual install' after the core system was done. Went all the way through, rebooted, got the same login (after jumpstarting the screen with an external monitor again) and then ran the command lines as suggested by izx.

Wonderful! It now starts up just fine into Lubuntu. A little slower than I was led to believe, perhaps slower than a previous version of Linux Mint 12 I ran on it, unencrypted, but maybe that is the penalty for encryption. I have to install LibreOffice, Firefox (and Zotero) for work purposes, which are apparently 'heavier', so we'll see.

must now figure out how to get it to use wireless (sigh...) but the installation is in.

Thanks both of you for your help, and special nod to izx!

B

share|improve this question
    
It sounds like your main problem is that the GUI is not loading. The alternate CD provides the option to install a command-line only system with no GUI. If you did that, this would explain the problem...and you could fix it by installing the GUI from the command-line. To test for this, log in to the command-line and run apt-cache policy ubuntu-desktop and apt-cache policy lightdm and see if it says there is any version of either installed; then you can report the results by editing your question. –  Eliah Kagan May 23 '12 at 16:16
    
If they aren't installed, run sudo apt-get update followed by sudo apt-get install ubuntu-desktop. If they are installed, try booting with nomodeset. Please also edit your question to indicate whether or not izx's suggestion to run startx helped. (I'm not posting these comments as an answer because they're very similar to his answer, just oriented toward requesting more information from you.) –  Eliah Kagan May 23 '12 at 16:19

1 Answer 1

That “686” surprises me,

Save yourself the trouble, i686 is 32-bit :) (anything that says x64 or x86_64 or amd64 is 64-bit)

If you chose the option to install an Ubuntu Desktop via the Alternate CD, just try entering startx and enter, to see if something starts up (I don't remember since I usually use the alternate CD to specifically install CLI systems).

If not, type sudo apt-get update && sudo apt-get upgrade -y, followed by sudo apt-get install XYZ, where XYZ can be ubuntu-desktop, or xubuntu-desktop, or lubuntu-desktop. Considering that you're on a D420, I recommend one of the latter two.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.