Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just recently bought a Lenovo z570, and for some reason the LiveCD has garbled text. I tried using Ubuntu 12.04 (amd64) Desktop/LiveCD (CD version). The text appears straight after trying to boot the CD, and it appears to not be rendering to the screen correctly. Possibly a graphics issue, since the laptop contains both an nVidia and an Intel card that is swappable with a soft-hardware switch, and in the UEFI/BIOS. Note: using the switch, and changing the UEFI/BIOS option didn't help.

Tried booting from USB, with no joy... but this could be because one of two things: Either a) the configuration used for the bootable USB drive I have*; or b) the fact that the Lenovo z570 has an (U)EFI BIOS, and this bootable USB was created (tested and working) on a regular BIOS (legacy) system.

Please look at the information I've provided below.

  1. I would like to know if it is possible to install Ubuntu to my system?
  2. Why am I getting garbled text and how can I proceed?
  3. Are there any specific changes I need to do?

If it helps, this is what I know about the laptop:

  • Contains a (U)EFI instead of a legacy BIOS. This is based on information found on the internet (e.g. Lenovo Forum).
  • Contains 4 partitons: 200MB (NTFS, System, Active, Primary), 654.69GB (NTFS, Boot, Page File, Crash Dump, Primary, Contains Windows 7), 29GB (NTFS, Logical, Contains Drivers/OEM Apps, Label: LENOVO), 14.75GB (unknown filesystem, OEM Partition, used for OneKey Recovery).
  • Windows 7 Home Premium 64-bit (OEM) is preloaded.
  • Despite using (U)EFI, Windows is preloaded in legacy mode! This is checked using a tool called "bcdedit" in Windows 7 which results in the "Windows Boot Loader" saying the path is "\windows\system32\winload.exe", this should show "winload.efi" if it was booted in EFI mode.
  • The HDD is partitioned using MBR instead of GPT.

Some of the Specs.:

  • Intel Core i7-2670QM (2.20GHz)
  • Intel HD Graphics 3000
  • nVidia GeForce GT 540M
  • CUDA/Optimus configuration graphics.
  • 750GB HDD
  • 6GB RAM

Side Note: I have a feeling the CUDA/Optimus configuration is where the problem lies, however I must point out that I did change this in the (U)EFI/BIOS/CMOS from Optimus to UMA (or the internal Intel graphics card). Neither way allows me to boot the CD without the garbled text.

*Configuration of the bootable USB drive: - Ext3 filesystem. - Bunch of ubuntu iso files (i.e. 10.04 to 12.04, both i386 and amd64) in a subdirectory called "iso". This is so I can install it anywhere, anytime, or to use as a LiveUSB on any machine for diagnostics, tweaks or fixes. - Grub2 bootloader. - Chain-loading the iso files (or iso loopback). - grub.cfg manually configured each time a new iso is added.

share|improve this question
1  
Just thought I'd add, the screen with the fuzzy/garbled text only seems to have 3 options to pick from. I found this out when pressing the down key and counting, the screen only flickers once I press the down key, and after the 2nd press there are no more flickers. Press up twice does the same. –  hazrpg May 23 '12 at 13:36
1  
Bhargav: Definitely a UEFI system not legacy on my Lenovo Ideapad Z570. Booted up "Acronis True Image Home", and the first thing on its bootloader says that it was booted into "EFI mode". So this confirms that the disc is at least detecting a (U)EFI bios not a legacy one. –  hazrpg May 26 '12 at 1:05
1  
Ur right.. I did a Google search on Phoenix SecureCore Tiano(which is the 1st thing I see at Power-ON) and concluded that my system is also running UEFI.. I've got a shitty windows 7 home basic, will scrapping it altogether solve the problem ?? Any Idea about it ?? –  Bhargav May 26 '12 at 2:19
1  
Great, glad you could confirm you have a UEFI too. My system came with Windows 7 Home Premium. I don't think scrapping it will solve the problem, since the problem seems to be at a lower level. The changelog for the UEFI update even mentions something about fixing a bug with booting non-windows OS's. If you want, I would recommend trying to boot an alternative distro of Linux and see if that boots up... if that works then we can narrow the problem down. Try using something that comes with Grub2 (Debian, Mint, etc) and something with LiLo (e.g. Fedora, OpenSUSE, etc). –  hazrpg May 26 '12 at 16:26
1  
Any joy @Bhargav? –  hazrpg Jun 15 '12 at 11:25
show 4 more comments

3 Answers 3

up vote 1 down vote accepted

Since no answer here was applicable to the solution I did to get it to work. Here is how I fixed it:

Reference: There is a forum post about this problem too, along with my responses. Found here. Also, the laptop I'm using is a Lenovo Ideapad Z570.

WARNING: Flasing your BIOS may brick your device, or render it unbootable. Do this at your own risk.

  1. Grabbed the latest version of the (U)EFI/BIOS from the Lenovo support website. Link to the en-GB version for the Lenovo Ideapad Z570 here.

  2. Flashed using the executable downloaded inside Windows 7.

  3. Rebooted, and tried booting the CD again. No joy.

  4. Opened the UEFI/BIOS using the F2 key. Picked the reset to default settings option.

  5. Rebooted, pressed F2 key again, changed the boot order to: USB:FDD, USB:HDD, USB:CD, HDD, Network. Saved & Exited.

  6. Rebooted, tried to boot from CD. Hurray, no more garbled menu! All options also now work!

  7. Tried this several times, to make sure it wasn't luck, booted fine each time. All options always worked. Note: Error still shows up however that the prefix isn't set. Also, still couldn't boot from USB at all... but I think this is due to an incompatible device since the UEFI/BIOS doesn't detect it at all. The drive is a SanDisk Cruzer 8GB (SDCZ36-008G) for reference. This one is similar (the one I have is an older model though, but colours are the same).

I won't mark this as a true answer until the other guys having the same issue can actually repeat this process successfully.

share|improve this answer
1  
That's quite a risky move.. Great that you got it working. I'm not taking that route, I'm heading out to research more on this issue. –  Bhargav May 26 '12 at 2:22
1  
Been flashing the BIOS on systems for 10 years (even since I was 13), and never had any troubles so far. PS3 updates for e.g. is a firmware flash. Did android flashes, laptops, computers, routers, consoles, mobile phones (i.e. the old nokia's via serial cable), random embedded systems, etc... and never seen a problem with flashing. Only advice, make sure the battery is fully charged, make sure you do it from a fresh boot (i.e. don't open anything up), use the software they give you (or methods they recommend), etc... and you should be fine. But the risk is always there. –  hazrpg May 26 '12 at 3:37
1  
Flashing isn't always a bad idea, if it helps fix problems. For more information about why to flash, the risks, and ways to avoid the risks read this guide: pcnineoneone.com/howto/biosflash1. Note: Usually flashes fail due to power failure, or incorrect BIOS version (or device). Bare in mind, most Windows-based flasher tools (esp ones from the manufacturers themselves) won't flash if it thinks there will be any problems doing so (e.g. downloading the wrong one, not enough power, etc). Power failure, wrong versions, and running too many apps is the main cause for problems. –  hazrpg May 26 '12 at 3:58
    
Flashing the BIOS does not void the warranty btw! Read the post here from the admin themselves: forums.lenovo.com/t5/W-Series-ThinkPad-Laptops/… if in doubt, take it to your nearest service centre, and ask for a BIOS update. Possibly the shop you bought it from will do it too. –  hazrpg May 26 '12 at 4:01
1  
I'm glad to hear you got it working. I agree that flashing the firmware, although not a task to be undertaken lightly, is also not "quite... risky." Hardware manufacturers make firmware updates available for valid reasons -- such as fixing bugs that prevent OS installers from booting! Be careful when you're doing it, and unless you're an expert, flash only firmware updates that have been released by the hardware's manufacturer. –  Rod Smith May 26 '12 at 4:53
show 1 more comment

It looks like the boot loader is having trouble with its fonts. You may be able to get started by just selecting an option and pressing the Enter key. (Picking the right option may be hit-or-miss, though; be prepared to try them all.) Since Ubuntu doesn't use exactly the same font code for itself as the boot loader uses, there's a good chance it will all work normally thereafter. The boot loader that Ubuntu will end up installing to the hard disk will probably not give this problem. If it does, you may need to switch boot loaders. (Fortunately, there are several available that will do the job.)

One more note: Before proceeding with Ubuntu installation, check the boot mode used by the installer. You can do this by checking for the existence of the /sys/firmware/efi/ directory. If it's present, you've booted in EFI mode, and you should try to force a BIOS-mode boot instead. You might be able to do this by using firmware options or by removing the EFI-specific boot files from the installation medium. (For an Ubuntu CD, the easiest way to do this is to download the Mac version, which supports BIOS booting but not EFI booting.)

share|improve this answer
    
I'll give that a shot and see what happens (using the Mac version). However I tried pressing enter on the first 2 options, nothing follows thereafter. I might try again and see if its just because its taking a while to boot off it though... thanks for the advice. –  hazrpg May 23 '12 at 15:53
    
Using the Mac/amd64 version of the CD didn't boot at all. Also, when booting the regular amd64 disc all options wouldn't work! They just simply froze. –  hazrpg May 26 '12 at 1:03
    
Sorry to drag this old question back out, but I've noticed that the garbled text has come back - despite having done a firmware update and got it working. Seems when I changed the partition to GPT (instead of the MBR it came with), along with installing Windows 7 Pro... the gabled text came back. However selecting the first option worked, unlike the first time. A quick side note: The alt. disc is not usable because the text is also garbled for that... however the desktop edition works fine. –  hazrpg Jun 15 '12 at 11:25
add comment

I had a similar problem with my Ideapad P500 when trying to boot Clonezilla from DVD.

What I did to solve it was simply switch the BIOS from EFI to legacy mode and then set the boot order as you normally would. As soon as Clonezilla wasn't using UEFI, the text displayed correctly.

With the pre-installed Windows 8 machines, you have to get to the BIOS via Settings > PC Settings > General > Advanced Restart, etc. while it's in UEFI mode, so it's also nice switching back to legacy just so I don't have to go through 20 steps to access the BIOS.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.