Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On a Sony Vaio VPCEG, bluetooth is not working properly:

  • The gnome-shell bluetooth indicator (at the main bar) shows the bluetooth is on, but when I try to switch visibility on it simply doesn't turn on.

  • When I open the bluetooth configuration dialog, the on/off indicator shows me the bluetooth is off. And when I try to turn it on it simply does not turn on.

The following is outputted by lsusb command:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 0c45:64be Microdia 
Bus 001 Device 004: ID 0489:e027 Foxconn / Hon Hai
Bus 002 Device 014: ID 4971:ce22 SimpleTech

======

Update: Output from rfkill list:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: sony-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: sony-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

What should I do to really activate the bluetooth?

share|improve this question
    
Finally found a response. How can I answer my own question? –  marcioAlmada Sep 6 '13 at 1:54
    
can you tell me how you have solved your problem? I'm facing the same problem.... –  pinkpanther Mar 18 at 22:23

3 Answers 3

This is not a fix, but it can solve the problem temporarily.

If you use dual-boot between Ubuntu and Windows, boot to Windows first. Then turn on the hardware switch for wireless.

After that, reboot into Ubuntu. Bluetooth will work now.

share|improve this answer
    
not working here –  marcioAlmada May 23 '12 at 21:09
    
What about wi-fi ? It works fine..? –  dixoncx May 24 '12 at 7:14
    
yep, wi-fi works fine and it turns on and off normally. –  marcioAlmada May 24 '12 at 11:49
    
Can you post output of rfkill list ? –  dixoncx May 24 '12 at 19:35
    
just added rfkill list output to the question's body :] –  marcioAlmada May 24 '12 at 20:14

I have vaio VPCEG35EN model. I enabled wifi by blacklisting acer_wmi module , but bluetooth is not working even though its always on in windows, and no soft or hard blocking in linux. Morever I doubt bluetooth hardware recognized in linux may not be correct because its an atheros bluetooth not foxconn. anyway here is output from lsusb and rfkill

parijat@UbuntuBook:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 0c45:64be Microdia 
Bus 001 Device 004: ID 0489:e027 Foxconn / Hon Hai 
parijat@UbuntuBook:~$ rfkill list
0: sony-wifi: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: sony-bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
3: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
share|improve this answer

I have a Vaio vpceg too, and I was searching around for answers and discovered that the problem occurs when you wake up the device. As dixonck says, if you reboot into windows, turn Bluetooth off and on and restart without shutting off the laptop, and then enter Ubuntu, you will see that Bluetooth works. However, if you switch off Bluetooth or shut down the laptop, it will not work.

Isn't a Ubuntu issue, is a Linux issue, i have tested it in several distros and it happens in them all.

I think Sony makes a hardblock that completely stops the Bluetooth devices.

share|improve this answer

protected by Community Aug 20 '12 at 14:36

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.