Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded the deb, following the answer in this question:

How can I get swftools installed?

When I run:

sudo dpkg --install swftools_0.9.0-0ubuntu1_i386.deb

I get:

The following packages have unmet dependencies: 
 swftools:i386 : Depends: libgif4:i386 (>= 4.1.6) but it is not going to be installed
                 Depends: gsfonts:i386 but it is not installable

I tried calling sudo apt-get -f install which removed the manually installed package, and then installed libgif4 and gsfonts using apt-get, however libgif4 seems to be the wrong version (I'm thinking 4.1.9 as it's the latest), and I can't for the life of me figure out how to get it to install version 4.1.6. And as far as I can tell gsfonts is installed, I'm not sure why I'm getting that error message.

What should I do? I need to batch convert 92 animated gif images to web-optimised swf, and I was planning on doing this using gif2swf.

share|improve this question
up vote 1 down vote accepted

Try installing from this PPA:


and report back of any dependence issues.

share|improve this answer
That's amazing. How did you find that PPA? It appears to have installed without any issues. I installed swftools. I can run pdf2swf, however cannot run gif2swf. It simply states that the command does not exist. Any ideas? I'm running find on the system now. – abkai May 23 '12 at 12:42
@abkai: did you get anywhere with your problem? I've encountered exactly the same difficulty – Nicholas Apr 17 '15 at 2:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.