Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm unable to install bleachbit on my laptop running Ubuntu 12.04. The Ubuntu Software Centre shows that the package is available from the Universe software source and I have the option to "use this source" but after that, it gets stuck while quering software sources.

How can I fix this problem? It's occurred to me that perhaps this could be from software sources being deleted in my configuration. If so, can someone tell me the default list of software sources?

enter image description here

enter image description here

plz help me out and sorry for my poor english

share|improve this question
Bleachbit works fine on Ubuntu 12.04. If you dont want to use bleachbit, then install ubuntu tweak. it also has a janitor fuction which works perfectly. – Curious Apprentice Feb 5 '13 at 20:04

I wouldn't even try it at this stage to put it on Ubuntu 12.04. It has got some issues and is not working properly. I updated my desktop PC and two laptops to 12.04 by fresh install and installed bleachbit on all of them.

Bleachbit would scan and do its job but as soon as it finished it would cause the PC to momentarily freeze then say there has been an internal problem with Ubuntu and it would send off an error report. This happened on the Desktop as well as the two laptops. There is obviously an issue there with 12.04 and Bleachbit. Every time I used it it would cause the same error. Not wanting to damage the operating system I Uninstalled it all three computers.

Having looked at other forums it appears some others are also having various problems with it. I will wait until a version for 12.04 actually comes out from the bleachbit website and I will try it again.

I have used it previously with other versions of Ubuntu and it has worked OK with them.

share|improve this answer

Restart your system and make sure you have added the Universe and source respositories. This can be done with in the Ubuntu Software Center located in the Unity launcher.

After starting it you should go the the Unified Menu on the very top right, then Edit, then Software Sources. The second line ends with "(universe)" and the bottom line says "Source code".

Select both. You will be prompted for your password to make these changes. Close that window.

You should then be able to install the package.

share|improve this answer

Go to the BleachBit web site, click on downloads, and get the latest version. The web site always has .deb files for the latest versions of Ubuntu.

share|improve this answer

You can try installing bleachbit from the command-line,if installing from the Ubuntu software center not working properly.

Open a Terminal window (press Ctrl+Alt+F2; or press Alt+F2, type gnome-terminal, and press Enter). Then run these two commands (type or paste them in and press Enter):

sudo apt-get update
sudo apt-get install bleachbit
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.