Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed Ubuntu 11 with gnome and in some point the text in the programs becomes unreadable like this.

distorted text in Eclipse

It's not only the text, but even the desktop background looks awful. I've tried to add section in xorg.conf, but it didn't helped out.

Section "Device"
    Identifier   "g33/X3000"
    Driver   "intel"
    BusID        "PCI:0:2:0"
    Option       "ModeDebug"  "on"
    Option       "MonitorLayout" "LCD,VGA"
    Option       "DevicePresence" "true"

And this is what the lshw returns about the VGA

         description: VGA compatible controller
         product: 82945G/GZ Integrated Graphics Controller
         vendor: Intel Corporation
         physical id: 2
         bus info: pci@0000:00:02.0
         version: 02
         width: 32 bits
         clock: 33MHz
         capabilities: msi pm vga_controller bus_master cap_list rom
         configuration: driver=i915 latency=0
         resources: irq:16 memory:dfe00000-dfe7ffff ioport:8800(size=8) memory:e0000000-efffffff memory:dfe80000-d$
share|improve this question

No idea of the actual answer, but here are some things to think about:

For the last year or two, many, if not all, settings have been migrated out of Xorg.conf. I think they ended up in hal. If this is the case for the settings in question, changes in the Xorg file would have no effect. I ran into this when I was trying to fix touchpad issues. I've heard some rumblings from the horizon that the whole X11 system is being depreciated in the not too distant future. (google wayland).

Screen shots are great, but I'm not sure what I'm seeing. It looks like some of the characters are not in the "English" (iso-whatever) character set. If that's what you're seeing, check your language and font settings for your desktop and individual applications. Also check your locale settings and make sure you're not "turning Japanese" ;)

Also, check what fonts you have installed. There should be a font manager in your system settings. Linux comes with only a few installed by default (but there should be more than enough to get a display like the one you showed to work right.) There's usually also an option to import Windows fonts if Windows is installed on your system.

share|improve this answer

I had the same problem and it seems the problem is in driver of video of the Intel.

00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)

In my case, was solved to the install the generic driver vesa and set it up in the xorg.conf but I can not use gnome 3.Has any solution for this? I use the fedora.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.