Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using ubuntu 10.04 with qemu-kvm installed. I bridged my eth0 to br0. My problem is that The host OS loses connection. Here is my interfaces file

 auto lo
 iface lo inet loopback

 auto eth0
 iface eth0 inet manual

 auto br0
 iface br0 inet dhcp
         bridge_ports eth0
         bridge_stp off
         bridge_fd 0
         bridge_maxwait 0
share|improve this question

3 Answers 3

Your interfaces file looks right. Are you sure it isn't an issue with your network setup? How are you determining that the host OS is losing connection (i.e. dropped ping packets, trouble downloading files, etc)?

You may need to give qemu the inheritable CAP_NET_ADMIN capability, for 64-bit:

sudo setcap cap_net_admin=ei /usr/bin/qemu-system-x86_64

or for 32-bit:

sudo setcap cap_net_admin=ei /usr/bin/qemu

For detailed instructions on setting up a bridged NIC for KVM, see my blog post, http://john.wesorick.com/2012/01/setting-up-bridged-network-interface.html.

share|improve this answer

Give a try to these two scripts I posted a couple of minutes ago, maybe they can help you out with your problem.

share|improve this answer

You haven't said anything about how your guests are defined. This reference suggests using the paravirtualized virtio rather than the default network NIC model for performance and reliability.

Per the reference: "This improves the network performances by a lot (nearly a factor of 10) and corrects an issue some people reported with their network connections going away after a period of time or data transfer."

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.