Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Installed kdm and used it as default. After i login into unity through i do not see my username.But if i go back to using lightdm, i have no problems.

Anyone knows how to use kdm as default and still not lose username in unity..?

share|improve this question
    
Was it present when you first installed / updated to Ubuntu 12.04 ? –  david6 May 23 '12 at 7:48
    
yes it was present.. –  tanmay.01 May 27 '12 at 6:25
    
Mine disappeared on 11.10 (after some update), but is present on new install of 12.04 LTS (so far) .. –  david6 May 27 '12 at 6:28

2 Answers 2

This happened to me once-- Try this command in Terminal:

sudo apt-get install indicator-session

What may have happened is that the package was deleted. Like I said, it happened once to me, so thiS MAY (I can't stress that word enough) work for you. :)

share|improve this answer
    
yes tried this also ...but in wain –  tanmay.01 May 23 '12 at 7:08

To re-enable the username on Unity panel, in terminal:

gsettings set com.canonical.indicator.session show-real-name-on-panel true

To disable, simply change true to false:

gsettings set com.canonical.indicator.session show-real-name-on-panel false

Note: You must reboot for these changes to take effect.

share|improve this answer
    
I did say it in the question this is not working –  tanmay.01 May 23 '12 at 3:38
    
@tanmay.01 If you were referring to the GUI for dconf, there shouldn't be an option for session under com > canonical > indicator, although I do not know why. But the show-real-name-on-panel boolean key should definitely work in defining the state of your username in the panel. Please give the commands a try in your terminal, and be sure to reboot. Get back to me! :) –  loklaan May 23 '12 at 5:35
    
Nope .. its not working.. in last 1 year this is the first time unity is troubling me.. –  tanmay.01 May 23 '12 at 6:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.