Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Yesterday (05/21) I upgraded my Ubuntu 12.04 kernel:

uname -a:

Linux vi 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

After the reboot all my mounts of external Samba shares stopped working.

When I execute:

sudo mount -t cifs // /mnt/video

The result is:

mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

And dmesg shows:

[ 2785.792456] cifs: Unknown symbol locks_delete_block (err 0)

If I execute:

sudo modprobe cifs

The result is:

FATAL: Error inserting cifs (/lib/modules/3.2.0-24-generic/kernel/fs/cifs/cifs.ko): Unknown symbol in module, or unknown parameter (see dmesg)

And dmesg shows again:

[ 5811.742563] cifs: Unknown symbol locks_delete_block (err 0)

Is there any known workaround for this?

share|improve this question

Have you tried to reboot? I really, really hate asking that about Linux, but it fixed it for me.

share|improve this answer
Thanks, you can see above that the problem was a bit harder to resolve. – Gustavo V. May 23 '12 at 21:20
Every time I upgrade my kernel, I have to reboot before my CIFS mounts will work. Do you happen to know why a reboot fixes this? [Also, reloading the module in question seems to fail silently.] It'd be great if I could work around this without a reboot. – Robbie Nov 30 '12 at 15:32

Problem solved!

While trying to resolve this issue I broke my computer's GRUB. I could not find time to restore the system until an hour ago, so please, excuse me for the delay in my answer.

Thanks a lot, reverendj1 & Bruno!

reverendj1: The different kernel version was the correct clue, it produced the missing symbol in cifs.ko.

The problem, incredibly, was the consequence of an undetected USB disk: The one I use to boot Ubuntu up on a RAID.

As Ubuntu fails to mount the USB disk (that I have on fstab mounted to /boot), it creates a dummy /boot on the raid that of course does not exist during startup phase at BIOS, but it is the only one that exist during normal computer operation.

As I updated the kernel, the updated kernel (#38) was written to the dummy boot. The "real" (during startup) kernel (the older #37) remained in the external USB disk that is visible only during startup.

The only effect that I could perceive from this kernel mismatch was that the cifs driver could not load.

share|improve this answer

Reinstall cifs-utils and reboot. This works for me.

sudo apt-get --reinstall install cifs-utils && sudo reboot
share|improve this answer
The reinstall is immaterial. It's the reboot that's important. – David Krider May 23 '12 at 18:17
You can see bellow that reverendj1 made the same suggestion yesterday. Thanks anyway. – Gustavo V. May 23 '12 at 21:21
Please don't script a reboot into anything you post somewhere like this. People will copy and paste without thinking and then accidentally reboot their server. – Paul Thompson Aug 26 '13 at 15:11

I would try to reinstall smbfs:

sudo apt-get --reinstall install cifs-utils
share|improve this answer
Thanks for the suggestion. but it did not work. – Gustavo V. May 22 '12 at 20:29
Have you tried a full update?, as in sudo apt-get update && sudo apt-get dist-upgrade – reverendj1 May 22 '12 at 20:31
@GustavoV. The package should be called cifs-utils not smbfs, try re installing cifs-utils as sugested here and shoot any errors in to your question if you see them – Bruno Pereira May 22 '12 at 20:33
I updated the answer with the correct package. I always get confused between those. – reverendj1 May 22 '12 at 20:36
I am still checking the full update... one minute please. – Gustavo V. May 22 '12 at 20:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.