Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I mount my Android phone with USB cable to Ubuntu 12.04 I get "these files are on a digital audio player" and open with rhythmbox in nautilus.This means that I am not able to see any file within my android.

Is it possible to disable the recognition of digital audio player and just list all files as usual?

EDIT

I found the issue. The issue was completely different than I thought. I actually have a Samsung galaxy S2. If you plug in the phone via USB you can see the device but you are not able to see any files.

But if you follow this guide, you will be able to see all files;

http://www.the-computer-geek.co.uk/?p=435

Thanks everybody for your efforts.

share|improve this question
    
The files should be listed as usual (in addition to the "these files..." bar at the top) –  8128 May 22 '12 at 19:51
1  
I thought so also but I am not able to see any file. Probably it is something else that cause this issue. –  ingi May 23 '12 at 18:38

2 Answers 2

up vote 1 down vote accepted

Each USB device presents itself to the operating system with a device class code. This determines what kind of device is plugged into your computer and thus enables your OS to initiate class dependent actions.

It is likely that your phone sends the device class identifier 01h Audio to Ubuntu. Therefore seemingly correct Rhythmbox is opened as we believed it was an mp3-player.

Unless you are able to change this code from settings on your phone the easiest approach to avoid starting a media player is to turn off the default behaviour on what to do when a "audio"-USB-device is plugged in.

A more basic approach would be to define a udev rule for a given device.

We have no experience with this software, but you may also be able to change the USB mode of a flip-flop device with the help of usb-modeswitch Install usb-modeswitch.

See the instructions on the support page for details on usage.

share|improve this answer
    
Yes I thought it was something like that. Thanks for you help anyway. –  ingi May 23 '12 at 18:40

You may disable this behaviour by going to system settings, removable media and select the 'do nothing' option.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.