Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm a first time Ubuntu user. Just installed 12.04. Only the top half of the display paints, and when I reboot, the screen goes black. My only work around is closing the laptop until it hibernates, then opening lid. Then I can log in, but only top half of display works. Very frustrating.

Is this a known bug? Anyone else experiencing this?

thanks.

Jack

share|improve this question
    
I have the same problem with my mini 12 but have noticed a slight variant - if I boot and don't have a network connection I have this problem. But if I'm connected, e.g., by pulling in a cat5 cable instead of relying on wifi, then simply logging out and logging back in will give me the full screen. (I think I do have to do an ipdown/ipup on one of the virtual terms first.) –  user78683 Jul 23 '12 at 1:00
add comment

2 Answers

I strongly suspect you have an Inspiron 1010 with Intel's gma500, aka, Mini 10, at least the symptoms are exactly the same. The lack of Linux support for gma500 is very well known, and yes, many Linux users have experienced the same problem. Hope that answers the questions. If interested, you can search for more info, there was a lot of discontent when people still hoped that Intel might provide a working driver. Here's a good example.

In case you are also interested in working around the problem, please follow the Wiki Page (or the steps below). Option 1 should do the trick.

Here what should be done:

In a terminal window, run

gksudo gedit /etc/default/grub

Find the following line: GRUB_CMDLINE_DEAULT="quiet splash"

Add console=tty1 in between the quotes, the end result looking as follows

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash console=tty1"

Save and exit, then run sudo update-grub.

share|improve this answer
add comment

I have one of those Dell Inspiron Mini 1010s and ran into this problem when installing Ubuntu 12.04.

I did as above, but found I also needed to do Option 2:

Essentially the same as above, just remove splash from the GRUB_CMDLINE_DEFAULT options.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.