Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Currently testing Ubuntu 12.04 x64 for our development team. After upgrading from 11.10 I've been having video card issues. I'm using Nvidia GeForce GTX 460. When ever I try to launch Nvidia X server I get the following error message.

You do not appear to be using the NVIDIA X driver. Please edit your X configuration >file (just run nvidia-xconfig as root), and restart the X server.

I've tried running sudo nvidia-xconfig multiple times and rebooting with no success. I've also tried getting the nvidia-current driver from the x-swat repo

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

Followed again by a reboot did nothing for me but knock my resolution down to 800x600 Finally I've tried

sudo apt-get purge xserver-xorg 
sudo apt-get update 
sudo apt-get install xserver-xorg xserver-xorg-video-all 
sudo reboot

Does anyone have any thoughts or directions they could point me in? To the best of my understanding my video card is suppose to be supported.

share|improve this question
    
I've also tried installing the driver 302.07 directly from the nvidia site. I turned off x server and ran the installer from virtual terminal. I got an error that it was unable to find the kernel source tree for the currently running kernel. –  aczietlow May 22 '12 at 19:06

5 Answers 5

up vote 2 down vote accepted

After several hours of research I found a working solution to my problem. From reading all the other forum posts I a lot of other people are having the same issue with the Nvidia driver and Ubuntu 12.04. Here's what I did to solve the problem for me. It may be advised to make a back up before you start. As we will be compiling a new kernel and reinstalling all the Nvidia drivers. Proceed at own risk

Download the Nvidia driver from the Nvidia website here,

Open module black list

 gksudo gedit /etc/modprobe.d/blacklist.conf

Add these lines

blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv

Remove all previously installed Nvidia driver. Might want to print out the rest of the steps as you will be rebooting after this step

sudo apt-get --purge remove nvidia-*

Reboot your computer. You may have to interrupt grub to and boot it safe or single mode. Do this by holding shift during boot. From there enable networking and open the root terminal

sudo reboot

Once at the root terminal enter the following to upgrade kernel.

sudo apt-add-repository ppa:francisbrwn9/kernels
sudo apt-get update
sudo apt-get dist-upgrade

Next you should run the Nvidia installer, by changing directory to where you downloaded it.

cd ~/Downloads/
sudo sh NVIDIA-Linux-x86_64-195.36.24-pkg2.run

Next start gdm

sudo service gdm start

Reboot

sudo reboot
share|improve this answer

I had the same problem. My solution was to install the linux-headers package, then sudo nvidia-xconfig. Reboot and go!

share|improve this answer

Came across this question and just wanted to give an easier alternative for 12.10(not sure if its this easy on 12.04 LTS):

  1. Ctrl+Alt+F1
  2. login
  3. sudo stop lightdm
  4. run nvidia installer as root, say yes to the question about "do you want to try disabling nouveau"
  5. reboot
  6. repeat steps 1-4 answer yes to all questions
  7. sudo start lightdm
share|improve this answer

The above answer worked in my case as well (GeForce 450 GTS), but instead of adding the repositroy to upgrade the kernel, it required me to download and install the linux-source and linux-headers packages for my kernel version (uname -r) for it to work, but the good thing was that they are present in the main repository.

share|improve this answer

adding the "--no-x-check" argument to the "sudo sh NVIDIA-Linux-x86_64-195.36.24-pkg2.run" command, allowed me to run the installer with the X Server running

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.