Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 12.04 with Unity, which I suppose uses Compiz as well. I have Compiz Settings Manager, and make the top left and bottom left corners of my screen activate the "Scale" (like Exposé) function to scale and show all windows.

The problem is that when I restart the computer, the hot corners no longer do anything. I have to go back into compiz settings manager, delete the hot corner option, and then set it again. Something seems to be overriding or deleting the compiz hot corner setting on restart.

Update: Sometimes, the setting loses its footing even while the computer is running. I haven't figured out yet what triggers it.

share|improve this question
1  
Same problem with Ubuntu 12.04 on a Lenovo T410s. This problem also occures when I release the notebook from the docking station where a second tft is connected to. There is already a bug report: bugs.launchpad.net/ubuntu/+source/compiz/+bug/999939 –  Kevin Horst May 23 '12 at 10:27
1  
I was having the issue too. Try opening the terminal (CTRL+ALT+T) and entering compiz --replace . It replaces any window managers running (basically, restarts compiz). See if it starts remembering your settings. So far, it has mine. –  James May 24 '12 at 0:53
    
@James I just tested this after a fresh restart. hot corner was dead again, ran compiz --replace in a terminal, and now the hot corner is active again. thanks, hoping this stays. –  Michael Butler May 24 '12 at 14:04
1  
@Michael Butler Workarounds have stopped working with the switch to 12.10. –  James Nov 3 '12 at 16:28

5 Answers 5

up vote 20 down vote accepted

Main bug reports are at https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/986208 and https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/858845.

For 12.04

Semi-Permanent solution copied here:

  • Run gconf-editor from Terminal or Alt+F2
  • Navigate to apps > compiz-1 > general > screen0 > options
  • Edit the key: active_plugins gconf Navigation Path
  • Move "Scale" to the bottom of the list.
  • Move "Expo" to bottom right above "Scale" and underneath Unityshell. active_plugins key

I say "semi-permanent" because some software updates (Unity) may cause the plug-in order to get rearranged, so you may need to repeat these steps 2 or 3 times per month.

For 12.10 and 13.04:

The above fix stopped working with the upgrade to 12.10 and continues on with 13.04. There are proposed solutions for 12.10 & 13.04 at the bug report link above, but so far nothing solid.

Semi-Permanent solution for 12.10:

  • Run dconf-editor from Terminal or Alt+F2
  • Navigate to /org/compiz/profiles/unity/plugins/core
  • Edit the key: active-plugins dconf navigation path
  • Move 'scale' and 'expo' to last in the list. active-plugins key

Note that system updates may revert this fix and you may have to use dconf to fix it again.

Please continue to contribute to the bug report to get the problem fixed in 12.04 LTS, 12.10 and beyond.

share|improve this answer
1  
For at least one person, the dconf key in 12.10 is located at /org/compiz/profiles/unity/plugins-with-set-keys . I don't know if their configuration is different than a stock 12.10 download or not though. –  James Dec 20 '12 at 4:25
1  
Also works on 13.10. –  Prasad RD Nov 5 '13 at 9:29
    
I still have this bug in 14.04, but the solution no longer works. Instead it crashes everything. Neat. –  jco Jul 4 at 13:59

For those experiencing this issue in 12.10 try this

Changing the order in the dconf key:

"/org/compiz/profiles/unity/plugins/core/active-plugins"

to read:

['core', 'composite', 'opengl', 'decor', 'gnomecompat', 'resize', 'snap', 'move', 'regex', 'place', 'vpswitch', 'grid', 'widget', 'compiztoolbox', 'session', 'imgsvg', 'mousepoll', 'imgpng', 'animation', 'wall', 'unitymtgrabhandles', 'workarounds', 'ezoom', 'fade', 'unityshell', 'scale', 'expo']

Fixed the issue for me, in Ubuntu 12.10 64bit. I'm not sure if this is required but, for those that are saying it's not working for them, make sure you have "Ubuntu-Tweak" installed. I recall in researching this issue, coming across a claim that a dependent package installed with Ubuntu Tweak, corrects another issue with screen triggers being retained across reboots.

Also, I know this should be obvious, but if your machine won't do 3D acceleration these compiz plug-in's just plain don't work

share|improve this answer
    
Just an update it seems software updates change this setting back to the original ordering from time to time, requiring one to go back in and reset the ordering with scale and expo at the end. The last time I had to do this I was given some errors and had to go through resetting the order a few times before it finally took. It would seem the best way for this to be done would be with a script setting this order before each boot, unfortunately I don't know exactly how that would be done –  dginsd Nov 20 '12 at 14:29

My temporary solution is just running "Ubuntu Tweak" application once after every reboot. (Changing plugin order works too but it is temporary too. I need to rearrange them after reboot.)

share|improve this answer
    
that's odd, for me changing the plug-in order in gconf-editor fixes it mostly permanently even after reboots. Rarely the plug-in order gets changed back when there is a major update to Unity. So are you saying you just run Ubuntu Tweak and then close it, you don't have to change settings? –  Michael Butler Aug 29 '12 at 14:43
    
Yes exactly . I run Ubuntu Tweak and then close it . But you were right , i installed unity revamped i think that changed the order. After that i thought changing order does not work for me and never changed again, kept opening then closing ubuntu tweak . Now i changed the plugin order again and it works !! Thank you . and i am sorry for my half-wrong information !! –  descape Aug 30 '12 at 4:28

This comment solved the problem for me. Just disable the "Launcher Capture Mouse" in "Ubuntu Unity plug-in -> Experimental".

share|improve this answer
    
Doesn't fix it for me in 12.10 –  James Nov 11 '12 at 15:23

The answer by @James was pretty detailed and the screenshots did help a lot. However, Compiz was still forgetting the settings. "UnityShell" keeps getting to the end of the list after every reboot and messing up scale and expo.

I was able to solve the issue by locking the positions of the keys. You can do this using CCSM.

Open CCSM (CompizConfig) and click on preference and then Plugin List. Uncheck "Automatic Plugin Sorting." Ensure that Scale is the last entry and expo just above that. If you are using Scale addon, make sure it goes below scale.

Now restart the computer and Scale and Expo will load. You can also check the order of keys in conf editor and ensure that they hold their positions. Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.