Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just did a fresh install of Ubuntu 12.04 on a Dell Inspiron 1545, then downloaded & installed all the latest updates. Now when I create a new user postgres in the "User Accounts..." window, it creates the account, but it's not listed in the User Accounts window. Since it's not listed, I am not able to create a password or "enable" the account so they can login.

I have tried reinstalling Ubuntu 12.04 thinking there might have been a bug during installation, but I got the same thing again. Any ideas on how to fix this?

share|improve this question
    
Check the used id. If it is under 500 it will not show up. Get an UID above 500 and it will. –  Rinzwind May 22 '12 at 14:36
1  
gah, figured it out... any user named "postgres" is automatically hidden by Ubuntu. Apparently, Ubuntu reserves this username for PostgreSQL. Any other username will work. :-P –  Ken May 22 '12 at 14:51
1  
Glad you got it solved. Other than the problem with that particular user name, remember that whenever the gui won't cooperate, you can do just about anything from the command line in a terminal and you'll get much better feedback when something goes wrong. guis are nice, but when you already know what you want to do, the command line is often faster and easier. –  Joe May 27 '12 at 19:57
1  
If it weren't a Dell iwth Intel architecture, one could think that it looks exactly like the effects of a bug, which affects other accountsservice on other architectures like ARM or PPC -- described in the answer askubuntu.com/a/150950/19753 . –  imz -- Ivan Zakharyaschev Jun 14 '12 at 20:09
1  
Ken, please take a moment to come back and accept the answer (or add your own and accept it), so that the question is marked closed and future readers can benefit from it. –  izx Jun 17 '12 at 12:01

1 Answer 1

As you found out, Ubuntu reserves the postgres user for maintenance (upgrades, backups, etc.) and other internal tasks, which require that this "user" be able to login without a password. Consequently, postgres is hidden from the User Accounts list, even if you create that user manually.

To allow local PSQL connections with a password, you can use the createuser utility and grant that user admin privileges.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.