Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Has anyone been able to use the ZTE MF192 HSPA (Black) modem with Network Manager? If there's a way, please share with the rest of us.

share|improve this question

2 Answers 2

I have the same modem same problem, gave me headache till I found the magical solution, Sakis3g! Follow the instructions under "ubuntu" on http://wiki.sakis3g.org/wiki/index.php?title=Sakis3G_installation You might want to eject the cd-rom icon that appears first, until your modem light blinks blue. Then double click the script to run. Works 100% for me. Dunno what's up with the Orange dudes btw.

share|improve this answer

I got this device working with two steps:

1) Use this config file for usb_modeswitch (/etc/usb_modeswitch.d/19d2:1216):

########################################################
# ZTE MF192+ (PPP and pseudo-ethernet interfaces)

DefaultVendor= 0x19d2
DefaultProduct=0x1216

TargetVendor = 0x19d2
TargetProduct= 0x1217

MessageContent="555342430800498200000000000010FF000000000000000000000000000000"

2) With this config NetworkManager is able to connect, but dhcp client should be started manually:

sudo dhclient usb0

Or, patch modemmanager with this patch: https://mail.gnome.org/archives/networkmanager-list/2012-April/msg00043.html

share|improve this answer
    
Alexander, I tried out your link above, but don't know how to patch the modem manager. What do I have to do? - Martin –  user78452 Jul 21 '12 at 17:11

protected by Community Aug 21 '12 at 7:14

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.