Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an issue which could be a bug, but before reporting it, I want to make sure I'm not doing something wrong.

When watching a movie with VLC on fullscreen, approximately in 10 minutes the screen goes blank. This happens despite having the "Inhibit the power management daemon during playback" option checked. This even happens when I go to the Ubuntu's system settings > Brightness and Lock and set the "Turn screen off when inactive for: " to "Never". (actually, no matter what value I set it to, the screen always goes blank after 10 minutes or so).

The only way I managed to disable the screen blanking is using the command line utility xset: xset -dpms and xset s off (it's possible only one of these is necessary).

Now, one thing that could possibly cause this is that I removed both gnome-screensaver and xscreensaver packages, because I'm not using screensaver. I only use the power-management to blank the screen (I assume it's different thing than screensaver, but I might be wrong). When no VLC us running, the screen blanking works normally even without those packages. That is, the screen goes blank after whatever timeout I set in the Brightness and Lock settings. Only when VLC is playng (and possibly only when in fullscreen), this issue occurs.

So my question is: Is this a bug in VLC (or elsewhere in Ubuntu), or should I install back gnome-screensaver and/or xscreensaver to make it work correctly again?

I have Ubuntu 12.04.

share|improve this question
I seem to have the same problem with VLC. The screen blanks after 10 mins. I run xubuntu so I use the xfce4-power-manager, in which I of course have turned off screen going to sleep. I have also removed the xscreensaver packages. I couldn't find this "Inhibit the power management daemon during playback" option in VLC though. – user66295 May 26 '12 at 14:42
@hampus: You have to switch the preferences panel to advanced mode (there is a switch in the bottom right corner), then it will be on the first page. – adam May 27 '12 at 17:27
I just wanted to throw in this observation. I have the same problem, although not with useing VLC, rather XBMC. This indicates that this is not a vlc problem, rather a Ubuntu bug. I am running a freshly installed 12.04 – user77163 Jul 15 '12 at 14:17
Gnome or Unity. This happens on gnome for me, but not on unity. Is this the same problem for you? – BullfrogBlues Feb 27 '13 at 15:51
up vote 2 down vote accepted

Since VLC should automatically prevent the screen from blanking when playing any video (or should have a working option to do so), regardless of the user's settings outside VLC, this can quite reasonably be considered a bug. Go forth and report it!

You can comment with the URL of the bug report on Launchpad, so that other people (like me) who have experienced this problem can easily access, subscribe to, and (using the green "This bug affects..." link) indicate we are affected (which will automatically make the bug Confirmed and bring it closer to a Triaged state, so it can be worked on by developers).

share|improve this answer
Well, I would report it, but there is still small chance that it's not a bug. What I'm thinking is, that maybe VLC somehow uses one of the programs I removed (gnome-screensaver and/or xscreensaver) to tell the power management system to inhibit the screen blanking. If that would be the case, someone could say that I deliberately broke my system and it's not a bug. But I guess I can just report it anyway and wait what the VLC guys say. – adam May 27 '12 at 17:32
Ok, the bug was already reported by someone else. I just added a comment: – adam May 27 '12 at 17:42
@adam Even in that case, it would be a bug that VLC doesn't warn that the functionality is unavailable, when it's enabled in VLC. Anyway, thx for finding and commenting in the bug! – Eliah Kagan May 27 '12 at 17:46
you are right, this would be bug in any case. Have the accept :) – adam May 28 '12 at 20:43
Fixed in VLC 2.2.0-rc1 – iElectric Nov 11 '14 at 6:50

As an intermediate work-around, try installing Caffeine. Enter the following commands in a terminal.

sudo add-apt-repository ppa:caffeine-developers/ppa
sudo apt-get update
sudo apt-get install caffeine


  1. Run Caffeine from the Dash, which displays a small icon on the right side in your top panel. Caffeine and its menu in the top panel
  2. Click it once to display the Preferences. Caffeine preferences
  3. Check Start Caffeine on login.
  4. Use the Add button to add vlc (in lowercase).
share|improve this answer
I was about to downvote this for suggesting another play, but then I realized that caffeine != kaffeine. Nice workaround, helped me. – Sentry Dec 9 '14 at 18:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.