Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 on a Lenovo x61s Thinkpad. As the screen's rather small and I want to do some video editing, I thought I'd plug in a monitor and use that. The monitor is Relisys JM777 (quite old). When I plug it into my other computer, which is running Windows 7, it immediately mirrors the display; but when plugged into the Lenovo the monitor screen remains blank. The graphics card on the Lenovo is a "VGA compatible controller" according to SysInfo. Anybody got any suggestions? I'm quite new to Linux, so simple explanations would be greatly appreciated. The contents of my Xorg.0.log file can be seen at http://paste.ubuntu.com/1009855/ .

share|improve this question
1  
You should go in the System settings panel and check the Display options. Most likely on your system the default for a second screen is to leave it unactivated until the user configures it. –  T. Verron May 22 '12 at 13:45
    
It may help to have the monitor already plugged in when you boot. I'm not assuming that it will then come up, but you can then add the contents of your /var/log/Xorg.0.log file here. It may have something interesting to say about why it isn't being activated. –  John S Gruber May 24 '12 at 12:50
    
I see you have posted your log file and you are using the Intel driver. If Pretorix DHM's answer doesn't help I'd suggest pasting the output of the xxrandr command after the screen is plugged in to see if its a problem with the Displays program or with the driver. From the very last line of your Xorg.0.log file I would say that the driver is being notified that a new monitor is present as it is adding another framebuffer for it. –  John S Gruber Sep 12 '12 at 18:07

5 Answers 5

I had a similar problem with my HP Elitebook 8530w, which uses an NVidia Quadra graphics card. I use the recommended NVidia drivers in Ubuntu 12.04.

In Applications-->System Tools-->System Settings-->Display it will not detect my secondary display.

However when I go to Applications-->System Tools-->Administration there is the option Nvidia X Server settings. Here I can select another display which is being detected properly and I can immediately use my secondary display.

share|improve this answer

I had similar problems with Ubuntu 12.04 & EliteBook 8530w. External display didn't work. I changed NVidia display driver to a newer version and it helped. System Settings -> Additional Drivers.

share|improve this answer

According to /var/log/Xorg.0.log, the second screen was detected at startup. Notably this was a line starting with "NVIDIA". To actually enable it, you have to go to the "NVIDIA X Server Settings" window. Start it via Dash Home.

share|improve this answer

Go to the Dash button (purple and white on the top left) and then type Display. The Display control will show up. Click on it. After a few seconds you should be in the Display control panel and should see both displays. Click on the additional monitor and click on the Enable control.

Then press the Apply button. If everything looks good you can accept this configuration. If you don't do anything it will go back to how it was after 30 seconds.

If you want to use them both at the same time you can also uncheck the Mirror button and can move the screens relative to each other. Again, you must click on the Apply button to try it out. You will then be able to view different parts of a virtual desktop on the two displays and can move windows with your mouse to where they are most handy for you.

share|improve this answer
    
I was able to verify that T. Verron's suggestion works on my computer. These are the individual steps. There are individual commands to do this work using the xrandr command, such as xrandr --auto which would turn the second screen on. That might be useful someday if you wanted to script this. But you said you were a beginner so... –  John S Gruber May 22 '12 at 16:58
    
Thanks for your help, but I've still got problems, I'm afraid. I went into the 'Displays' dialog as suggested - initially it was only showing one display, the one for my laptop, but when I unchecked the 'Mirror' option a second one appeared alongside, labelled 'TEO 17"'. I couldn't see any 'Enable' option; the 'TEO 17"' display, when I clicked on it, was already showing as 'ON'. I tried switching it off and on again, then clicking Apply - my mouse disappeared off the right-hand side of my laptop screen, but the Relisys screen remained blank. –  Julian Le Saux May 24 '12 at 11:38
    
Okay, I switched on with the monitor plugged in, and had a look at the /var/log/Xorg.0.log file. Needless to say it didn't mean a thing to me, but here it is: –  Julian Le Saux May 25 '12 at 18:24
    
Sorry - my previous comment was unfinished, because I tried to paste in the contents of the Xorg.0.log file, but it was too many characters for the forum to accept. Is there a way round this? –  Julian Le Saux May 25 '12 at 18:33
    
I'd suggest you go back to your question--where most of your information is already accessible to every reader and commenter and past a link to your file. You can use paste.ubuntu.com to store the file and get a link for it. –  John S Gruber May 25 '12 at 22:05

I had a familiar problem with my HP probook 4416s, I tried all I can find by google but no one works for me, even did a lot of work to install AMD driver for my old video card.

But finally I solved my problem by re-plug-in my DVI wire hardly.

So if you can't solve it with answers above, don't forget to try this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.