Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I followed the instructions from here but I got the following error when trying to install gnome-shell-extensions-user-theme:

The following packages have unmet dependencies:
 gnome-shell-extensions-user-theme : Depends: gnome-shell-extensions-common but it is not going to be installed

Extra information:

Running Ubuntu with Gnome3

share|improve this question

3 Answers 3

gnome-shell-extensions-common depends upon gnome-shell-extensions, which already includes the user-theme extension, and so conflicts with the gnome-shell-extensions-user-theme package. There seems to be something wrong with the dependencies in that repository.

Anyway, you can simply install gnome-shell-extensions, which has the user theme extension. That's what I did and it worked.

Change themes using gnome-tweak-tool.

share|improve this answer

You may force gnome-shell-extensions-common package version to be provided by the same PPA you're trying to install gnome-shell-extensions-user-theme from. I'm wondering if you have different repos provide those packages in your sources...

share|improve this answer
    
So how would I do that (making sure they have the same repository/version) –  PatronBernard May 22 '12 at 17:31

In your Terminal, do this:

sudo apt-get install gnome-shell-extensions-common
sudo apt-get install -f 
share|improve this answer
1  
Didn't work, could you also tell me what that command should do? If I know what I'm doing I'll be able to formulate better questions. So far nearly every google source is "do this command, now this one" so I learn nothing at all. Thanks for the quick reply though... –  PatronBernard May 22 '12 at 10:16
    
hmm yeah :) , apt-get install -f will fix the broken pkg's(not successfully installed with dependencies issues also ). so easily we can fix them up with this . so i have given that to you . –  AgentCool May 22 '12 at 10:19
    
Okay, so it says this: 0 upgraded, 0 newly installed, 0 to remove and 156 not upgraded. The first time I ran it, it said something different (so it fixed something) but I still get the same error. Do I need to enter the commands from my link subsequently (in the same terminal session) or can I do it in separate sessions? –  PatronBernard May 22 '12 at 10:20
    
i have changed my answer , do it . i am sure that gonna help you . –  AgentCool May 22 '12 at 10:22
    
I tried that one already but it still says the same thing :P So weird, maybe I need a reboot? –  PatronBernard May 22 '12 at 10:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.