Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.04. I cannot login. I get to the grub menu and go root, delete my /home/user/.Xauthority file and change my password. I move /home/user/.profile to /home/user/profile, reboot, and I can login (this is fixed by moving .profile to some other name).

But if I am idle and Ubuntu displays the screensaver, I cannot login. I have pressed Ctrl+Alt+F1 and removed /home/user/.Xauthority. I check the existence of /home/user/.profile and it does not exist. There is no way for me to login to X from the keyboard connected to the box. I can ssh -CXY to the ubuntu box and login without any problem. Can someone help me fix this problem?

share|improve this question

1 Answer 1

how about creating your new /home/user/.profile:

# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
    . "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi

copy, paste, save ..

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.