Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If you run locale on an Ubuntu installation you get something like:

LANG=en_US.utf8
LANGUAGE=
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE="en_US.utf8"
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=

How come LC_ALL is unset? I know how to set it, but why doesn't Ubuntu set it automatically, like with the other LC_'s?

share|improve this question
    
I do not think it is recommended to do this because it will override all your other locale settings. –  Mitch May 22 '12 at 8:32
    
If you would like to know how to change that let me know. –  Mitch May 22 '12 at 8:32
add comment

1 Answer

up vote 12 down vote accepted

If LC_ALL is set it overrides the values of all the other LC_ variables. Hence setting it by default would have the same effect for your locale settings as setting all the LC variables but would make it more difficult to change only some of the values.

share|improve this answer
    
Makes sense, thanks :) –  Joril May 22 '12 at 8:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.